summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorston2022-10-13 00:02:42 +0800
committerston2022-10-13 00:02:42 +0800
commit34e3b201b3a5f2ac05266d15dc3e14bfa9b2fb94 (patch)
tree1f2d286ef3ecb310768460ea101b5f37b81d23d5
downloadaur-34e3b201b3a5f2ac05266d15dc3e14bfa9b2fb94.tar.gz
update
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD29
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ff742553094
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = go-musicfox
+ pkgdesc = Command-line Netease Cloud Music written in Go.
+ pkgver = 3.2.2
+ pkgrel = 1
+ url = https://github.com/anhoder/go-musicfox
+ arch = x86_64
+ license = MIT
+ makedepends = gcc-objc
+ depends = flac
+ depends = alsa-lib
+ provides = musicfox
+ conflicts = go-musicfox-bin
+ conflicts = musicfox
+ source = https://github.com/anhoder/go-musicfox/archive/refs/tags/v3.2.2.tar.gz
+ sha256sums = 3ee5f02e404898706a54a563d6185ed3c17a42457bdbba3fa31aac01b174e8ed
+
+pkgname = go-musicfox
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bea45de40a16
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/*.zip
+/*.zst
+/*.gz
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3990b113744
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=go-musicfox
+pkgver=3.2.2
+pkgrel=1
+pkgdesc='Command-line Netease Cloud Music written in Go.'
+url='https://github.com/anhoder/go-musicfox'
+license=('MIT')
+arch=('x86_64')
+provides=('musicfox')
+conflicts=('go-musicfox-bin' 'musicfox')
+depends=('flac' 'alsa-lib')
+makedepends=('gcc-objc')
+source=(
+ ${url}/archive/refs/tags/v${pkgver}.tar.gz
+)
+
+build(){
+ cd go-musicfox-${pkgver}
+ export GOPATH=${srcdir}
+ go build -o ../musicfox cmd/musicfox.go
+}
+
+package() {
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm755 "${srcdir}/musicfox" "${pkgdir}/usr/bin/musicfox"
+ install -Dm644 "${srcdir}/go-musicfox-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+
+sha256sums=('3ee5f02e404898706a54a563d6185ed3c17a42457bdbba3fa31aac01b174e8ed')