summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorston2022-10-13 00:22:25 +0800
committerston2022-10-13 00:22:25 +0800
commitd9e90a8f96fae8f8ea650109f461c9a393838b27 (patch)
treeb8dcde4ab12d8500143b35ec1fa0980b744fb512
parent34e3b201b3a5f2ac05266d15dc3e14bfa9b2fb94 (diff)
downloadaur-d9e90a8f96fae8f8ea650109f461c9a393838b27.tar.gz
update
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ff742553094..0185246b68fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,7 +11,7 @@ pkgbase = go-musicfox
provides = musicfox
conflicts = go-musicfox-bin
conflicts = musicfox
- source = https://github.com/anhoder/go-musicfox/archive/refs/tags/v3.2.2.tar.gz
+ source = go-musicfox-3.2.2.tar.gz::https://github.com/anhoder/go-musicfox/archive/refs/tags/v3.2.2.tar.gz
sha256sums = 3ee5f02e404898706a54a563d6185ed3c17a42457bdbba3fa31aac01b174e8ed
pkgname = go-musicfox
diff --git a/PKGBUILD b/PKGBUILD
index b3990b113744..233c5573d94f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,11 +10,15 @@ conflicts=('go-musicfox-bin' 'musicfox')
depends=('flac' 'alsa-lib')
makedepends=('gcc-objc')
source=(
- ${url}/archive/refs/tags/v${pkgver}.tar.gz
+ go-musicfox-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz
)
build(){
cd go-musicfox-${pkgver}
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
export GOPATH=${srcdir}
go build -o ../musicfox cmd/musicfox.go
}