summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorston2022-07-29 19:04:28 +0800
committerston2022-07-29 19:04:28 +0800
commit666a5c3e84cb328afb5451f6557e15f222347e05 (patch)
treed0ec99e3953a0b5950239f0f4fbf74714b887c03
parent51706e362cbf8a509139fb986c1e2257e6ffb453 (diff)
downloadaur-666a5c3e84cb328afb5451f6557e15f222347e05.tar.gz
format
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore4
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD7
4 files changed, 31 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 389f060eaa8f..8ad2b596df40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,7 @@ pkgbase = go-musicfox-bin
arch = x86_64
license = MIT
source = https://github.com/anhoder/go-musicfox/releases/download/v2.2.1/go-musicfox_2.2.1_linux_amd64.zip
- source = https://raw.githubusercontent.com/anhoder/go-musicfox/master/LICENSE
+ source = LICENSE
sha256sums = 0d923511165cc082ea0ab5917f5e3f3853de9d0a8d5e99cba2e9a61384a9d352
sha256sums = 20535828272932407c2f5172aeb714ac7b374a34e5ecb1825af509f2902cde54
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b20f0a2d9c3d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.zip
+/*.zst
+/src/
+/pkg/
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..293c59e320ae
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2015 - present Microsoft Corporation
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 60045a18143a..ad756245989c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,10 @@ pkgdesc='Command-line Netease Cloud Music written in Go.'
url='https://github.com/anhoder/go-musicfox'
license=('MIT')
arch=('x86_64')
-source=("${url}/releases/download/v${pkgver}/go-musicfox_${pkgver}_linux_amd64.zip" "https://raw.githubusercontent.com/anhoder/go-musicfox/master/LICENSE")
+source=(
+ "${url}/releases/download/v${pkgver}/go-musicfox_${pkgver}_linux_amd64.zip"
+ "LICENSE"
+)
package() {
install -d "${pkgdir}/usr/bin"
@@ -15,4 +18,4 @@ package() {
}
sha256sums=('0d923511165cc082ea0ab5917f5e3f3853de9d0a8d5e99cba2e9a61384a9d352'
- '20535828272932407c2f5172aeb714ac7b374a34e5ecb1825af509f2902cde54')
+ '20535828272932407c2f5172aeb714ac7b374a34e5ecb1825af509f2902cde54')