summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlizard2022-03-19 13:56:35 +0800
committerlizard2022-03-19 13:56:35 +0800
commitb9626d7a890015440d90686d55569a9d230342e2 (patch)
tree12e5c3c01ac7a03500b9eeded1a3e6739da19ed3
downloadaur-b9626d7a890015440d90686d55569a9d230342e2.tar.gz
submit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1568c5a08e65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = go-musicfox-bin
+ pkgdesc = Command-line Netease Cloud Music written in Go.
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://github.com/anhoder/go-musicfox
+ arch = x86_64
+ license = MIT
+ source = https://github.com/anhoder/go-musicfox/releases/download/v2.1.0/musicfox.linux
+ source = https://raw.githubusercontent.com/anhoder/go-musicfox/master/LICENSE
+ sha256sums = f2c75f9ff10db6e4a73b0bcb4128ecfbfb6887bccb0b6da64aebe1d574de5cc0
+ sha256sums = 20535828272932407c2f5172aeb714ac7b374a34e5ecb1825af509f2902cde54
+
+pkgname = go-musicfox-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1733f8288e8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+pkgname=go-musicfox-bin
+pkgver=2.1.0
+pkgrel=1
+pkgdesc='Command-line Netease Cloud Music written in Go.'
+url='https://github.com/anhoder/go-musicfox'
+license=('MIT')
+arch=('x86_64')
+source=("${url}/releases/download/v${pkgver}/musicfox.linux" "https://raw.githubusercontent.com/anhoder/go-musicfox/master/LICENSE")
+
+package() {
+ install -d "${pkgdir}/usr/local/bin"
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 "${srcdir}/musicfox.linux" "${pkgdir}/usr/local/bin/musicfox"
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+
+sha256sums=('SKIP' 'SKIP')
+sha256sums=('f2c75f9ff10db6e4a73b0bcb4128ecfbfb6887bccb0b6da64aebe1d574de5cc0'
+ '20535828272932407c2f5172aeb714ac7b374a34e5ecb1825af509f2902cde54')