summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhoream2023-04-12 17:06:31 +0800
committerhoream2023-04-12 17:06:31 +0800
commit89a91eeaf90429dfa1edc9e88c4a16e05f6f8c31 (patch)
treedc6479745e82a2a07ffe10a59f00010bb5bb7543
parentb5b8f437a25612eb70ce1d6537a420f19341fc4d (diff)
downloadaur-89a91eeaf90429dfa1edc9e88c4a16e05f6f8c31.tar.gz
Update to 4.0.1.r9.gff81a02
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 069f72049a6c..13188943c008 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = go-musicfox-git
pkgdesc = Command-line Netease Cloud Music written in Go (git version).
- pkgver = 4.0.0.r8.g73034d5
+ pkgver = 4.0.1.r9.gff81a02
pkgrel = 1
url = https://github.com/anhoder/go-musicfox
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index e454bbe128f4..2ed5f4d481e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Hoream <2175223953@qq.com>
_pkgname="go-musicfox"
pkgname="${_pkgname}-git"
-pkgver=4.0.0.r8.g73034d5
+pkgver=4.0.1.r9.gff81a02
pkgrel=1
pkgdesc='Command-line Netease Cloud Music written in Go (git version).'
url='https://github.com/anhoder/go-musicfox'
@@ -20,10 +20,20 @@ pkgver() {
}
build(){
- cd "${srcdir}/${_pkgname}"
make
}
+build(){
+ cd "${srcdir}/${_pkgname}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export GOPATH=${srcdir}
+ go build -o bin/musicfox -ldflags "-s -w -X go-musicfox/pkg/constants.AppVersion=v${pkgver}" cmd/musicfox.go
+}
+
+
package() {
install -d "${pkgdir}/usr/bin"
install -d "${pkgdir}/usr/share/licenses/${_pkgname}"