summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhoream2023-04-12 21:43:56 +0800
committerhoream2023-04-12 21:43:56 +0800
commitb50ea093b7b80a6bc600347145714c2b50f11b1e (patch)
treef7edfcd29435f4fcfba7a09413a20ca8eda01f2e
parentf3c43ca09cd0945a0341f140769e18184ddc1ac3 (diff)
downloadaur-b50ea093b7b80a6bc600347145714c2b50f11b1e.tar.gz
Update to 4.0.2
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 4 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fad88f997820..c66f2d4b9683 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = go-musicfox-git
pkgdesc = Command-line Netease Cloud Music written in Go (git version).
pkgver = 4.0.2.r1.gc78f3a7
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/anhoder/go-musicfox
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index b359d07e8e46..10648ae19fdc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _pkgname="go-musicfox"
pkgname="${_pkgname}-git"
pkgver=4.0.2.r1.gc78f3a7
_pkgver=4.0.2
-pkgrel=1
+pkgrel=2
pkgdesc='Command-line Netease Cloud Music written in Go (git version).'
url='https://github.com/anhoder/go-musicfox'
license=('MIT')
@@ -21,17 +21,9 @@ pkgver() {
}
build(){
- make
-}
-
-build(){
cd "${srcdir}/${_pkgname}"
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external"
- export CGO_LDFLAGS="${LDFLAGS}"
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export GOPATH=${srcdir}
- go build -o bin/musicfox -ldflags "-s -w -X go-musicfox/pkg/constants.AppVersion=v${_pkgver}" cmd/musicfox.go
+ go mod download
+ make
}