summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorimlonghao2018-06-23 22:20:11 +0800
committerimlonghao2018-06-23 22:20:11 +0800
commitc5cabdb743fbfab8d39380463e9024fa2d2fc8b3 (patch)
treec6b918f3a636f8a4d7d53d48a44df8df691df991
parente40f02cde31443706449000ed3766675b657ca4b (diff)
downloadaur-c5cabdb743fbfab8d39380463e9024fa2d2fc8b3.tar.gz
Fix the lib missing issue
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
-rw-r--r--config.conf8
-rw-r--r--go-nebulas-git.install10
-rw-r--r--go-nebulas.service3
5 files changed, 32 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 813a6e0c971a..805835b5b56f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = go-nebulas-git
pkgdesc = Official Go implementation of the Nebulas protocol
pkgver = r2209.78433128
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/nebulasio/go-nebulas
install = go-nebulas-git.install
arch = x86_64
@@ -24,10 +24,10 @@ pkgbase = go-nebulas-git
source = go-nebulas-git.install
source = go-nebulas-git.conf
sha256sums = SKIP
- sha256sums = 47fb517be710ac459c446f34d69728f3416ae51aeccb9045ecdf8443450433ff
+ sha256sums = a6cfe7b259320720830c190adf93329c80f85ef62019ca4fdb544cbb0fe6dbc5
sha256sums = f02573abd8979f50f4541b8e2c4b732f8ced823dc105b368d59b09e2591b3071
- sha256sums = 3e11da7d6ef33e69de2f65c8d77f41d0e937f6900fe064572170648e92350892
- sha256sums = 3b79cfec7c854ad35279c308068a56f499dee83db492b4ce7de3c1fb68890571
+ sha256sums = c950199571a367dff0987e9dac583199290df67565922386ff717d93b40a5183
+ sha256sums = 25c7cef2f26594514a5616bcc3965484dcd8dd7972f3e3e55087ec302aa6bebd
sha256sums = eba28579d2c1d1213ed5dc09f84d8244de20bca1828d9adfaac841b603b54f06
pkgname = go-nebulas-git
diff --git a/PKGBUILD b/PKGBUILD
index 4acaa491cb3b..9c3d7d80b6b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=go-nebulas-git
pkgver=r2209.78433128
-pkgrel=2
+pkgrel=3
pkgdesc="Official Go implementation of the Nebulas protocol"
arch=("x86_64")
url="https://github.com/nebulasio/go-nebulas"
@@ -20,10 +20,10 @@ source=("$pkgname::git+https://github.com/nebulasio/go-nebulas.git"
"go-nebulas-git.install"
"go-nebulas-git.conf")
sha256sums=('SKIP'
- '47fb517be710ac459c446f34d69728f3416ae51aeccb9045ecdf8443450433ff'
+ 'a6cfe7b259320720830c190adf93329c80f85ef62019ca4fdb544cbb0fe6dbc5'
'f02573abd8979f50f4541b8e2c4b732f8ced823dc105b368d59b09e2591b3071'
- '3e11da7d6ef33e69de2f65c8d77f41d0e937f6900fe064572170648e92350892'
- '3b79cfec7c854ad35279c308068a56f499dee83db492b4ce7de3c1fb68890571'
+ 'c950199571a367dff0987e9dac583199290df67565922386ff717d93b40a5183'
+ '25c7cef2f26594514a5616bcc3965484dcd8dd7972f3e3e55087ec302aa6bebd'
'eba28579d2c1d1213ed5dc09f84d8244de20bca1828d9adfaac841b603b54f06')
pkgver() {
@@ -53,16 +53,22 @@ package() {
install -Dm644 ${pkgname}.conf ${pkgdir}/etc/ld.so.conf.d/${pkgname}.conf
install -dm755 ${pkgdir}/usr/lib/${pkgname}
install -Dm755 ${_dir}/nf/nvm/native-lib/*.so ${pkgdir}/usr/lib/${pkgname}
+ install -dm755 ${pkgdir}/opt/${pkgname}/lib
+ cp -r ${_dir}/nf/nvm/v8/lib/1.0.0 ${pkgdir}/opt/${pkgname}/lib
+ cp -r ${_dir}/nf/nvm/v8/lib/1.0.5 ${pkgdir}/opt/${pkgname}/lib
# Install Binary
- install -Dm755 ${_dir}/neb ${pkgdir}/usr/bin/neb
- install -Dm755 ${_dir}/neb-crashreporter ${pkgdir}/usr/bin/neb-crashreporter
+ install -Dm755 ${_dir}/neb ${pkgdir}/opt/${pkgname}/neb
+ install -Dm755 ${_dir}/neb-crashreporter ${pkgdir}/opt/${pkgname}/neb-crashreporter
+ install -dm755 ${pkgdir}/usr/bin
+ ln -s ${pkgdir}/opt/${pkgname}/neb ${pkgdir}/usr/bin/neb
+ ln -s ${pkgdir}/opt/${pkgname}/neb-crashreporter ${pkgdir}/usr/bin/neb-crashreporter
# Install License
install -Dm755 ${_dir}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
# Add example configuration file
- install -d ${pkgdir}/etc/go-nebulas
- install -Dm644 config.conf ${pkgdir}/etc/go-nebulas/config.conf.example
- install -Dm644 genesis.conf ${pkgdir}/etc/go-nebulas/genesis.conf.example
- cp -r ${_dir}/keydir ${pkgdir}/etc/go-nebulas/keydir.example
+ install -d ${pkgdir}/opt/${pkgname}/conf
+ install -Dm644 config.conf ${pkgdir}/opt/${pkgname}/conf/config.conf.example
+ install -Dm644 genesis.conf ${pkgdir}/opt/${pkgname}/conf/genesis.conf.example
+ cp -r ${_dir}/keydir ${pkgdir}/opt/${pkgname}/conf/keydir.example
install -Dm644 go-nebulas.service ${pkgdir}/usr/lib/systemd/system/go-nebulas.service
}
diff --git a/config.conf b/config.conf
index 174ed2efd336..6d55c1cf86f8 100644
--- a/config.conf
+++ b/config.conf
@@ -12,9 +12,9 @@ network {
chain {
chain_id: 1
- datadir: "/var/lib/go-nebulas/data.db"
- keydir: "/etc/go-nebulas/keydir"
- genesis: "/etc/go-nebulas/genesis.conf"
+ datadir: "/opt/go-nebulas-git/data.db"
+ keydir: "/opt/go-nebulas-git/conf/keydir"
+ genesis: "/opt/go-nebulas-git/conf/genesis.conf"
signature_ciphers: ["ECC_SECP256K1"]
}
@@ -26,7 +26,7 @@ rpc {
app {
log_level: "info"
- log_file: "/var/lib/go-nebulas/logs"
+ log_file: "/opt/go-nebulas-git/logs"
enable_crash_report: false
}
diff --git a/go-nebulas-git.install b/go-nebulas-git.install
index f1cdfd842072..470992c7f7af 100644
--- a/go-nebulas-git.install
+++ b/go-nebulas-git.install
@@ -1,6 +1,8 @@
post_install() {
- echo "Example mainnet configuration files are located in /etc/go-nebulas"
- echo "You can delete the suffix *.example to use them"
- echo "Then, you can use \"systemctl start go-nebulas\" to start the node"
- echo "For more information, please visit: https://github.com/nebulasio/wiki/wiki"
+ echo ""
+ echo "> Example mainnet configuration files are located in /opt/go-nebulas-git/conf"
+ echo "> You can use the default config by deleting the suffix (.example)"
+ echo "> Then, you can use \"systemctl start go-nebulas\" to start the node"
+ echo "> For more information, please visit: https://github.com/nebulasio/wiki/wiki"
+ echo ""
}
diff --git a/go-nebulas.service b/go-nebulas.service
index 6132d450b146..c71bcb1f5953 100644
--- a/go-nebulas.service
+++ b/go-nebulas.service
@@ -4,7 +4,8 @@ Documentation=https://github.com/nebulasio/wiki
After=network.target
[Service]
-ExecStart=/usr/bin/neb -c /etc/go-nebulas/config.conf
+ExecStart=/usr/bin/neb -c /opt/go-nebulas-git/conf/config.conf
+WorkingDirectory=/opt/go-nebulas-git
[Install]
WantedBy=multi-user.target