summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRagnar Laud2023-11-18 02:25:20 +0200
committerRagnar Laud2023-11-18 02:25:20 +0200
commitb6988399db1440199030a9bf737c4631090acc3c (patch)
tree57c46926a3b3ec57c5d4f94eca7967df2f1b597d
downloadaur-b6988399db1440199030a9bf737c4631090acc3c.tar.gz
Create PKGBUILD
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rwxr-xr-xPKGBUILD32
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72c30216c299
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = go-pdirs-git
+ pkgdesc = Project directory resolver
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/xprnio/go-pdirs
+ arch = x86_64
+ license = MIT
+ depends = go
+ depends = make
+ provides = go-pdirs
+ conflicts = go-pdirs
+ source = git+https://github.com/xprnio/go-pdirs.git
+ sha256sums = SKIP
+
+pkgname = go-pdirs-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..313d5f16eaef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Ragnar Laud <ragnar.laud@hotmail.com>
+_pkgname=go-pdirs
+pkgname=$_pkgname-git
+pkgrel=1
+pkgver=0.1.0
+pkgdesc="Project directory resolver"
+arch=(x86_64)
+url="https://github.com/xprnio/$_pkgname"
+license=(MIT)
+depends=(go make)
+provides=($_pkgname)
+conflicts=($_pkgname)
+
+source=("git+$url.git")
+sha256sums=('SKIP')
+
+build() {
+ cd $_pkgname
+ make build
+}
+
+check() {
+ cd $_pkgname
+ make test
+}
+
+package() {
+ cd $_pkgname
+ echo "List of current directory"
+ ls
+ install -Dm755 "bin/go-pdirs" "$pkgdir/usr/bin/$_pkgname"
+}