summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoredward-p2020-08-21 04:17:02 +0800
committeredward-p2020-08-21 04:17:02 +0800
commit181a38a629dc7b1ffb1c09e02ba706df87ea5e0a (patch)
tree518171d37eefe8b790366965bd6e27ed677f78d7
parentf525f093519296ca0b58ddfd41b992fb36e41271 (diff)
downloadaur-181a38a629dc7b1ffb1c09e02ba706df87ea5e0a.tar.gz
go-stun-git: updated to r125.d587b28
-rw-r--r--.SRCINFO4
-rw-r--r--10-build-in-src.patch11
-rw-r--r--PKGBUILD13
3 files changed, 4 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6340ec471e7..8b6c5899c367 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = go-stun-git
pkgdesc = A go implementation of the STUN client (RFC 3489 and RFC 5389)
- pkgver = r116.be486d1
+ pkgver = r125.d587b28
pkgrel = 1
url = https://github.com/ccding/go-stun
arch = x86_64
@@ -10,9 +10,7 @@ pkgbase = go-stun-git
provides = go-stun
conflicts = go-stun
source = git+https://github.com/ccding/go-stun.git
- source = 10-build-in-src.patch
sha256sums = SKIP
- sha256sums = 1cc32a4bace519635092657b861fbf4d02753ec7480790c738f133fba97cc4fd
pkgname = go-stun-git
diff --git a/10-build-in-src.patch b/10-build-in-src.patch
deleted file mode 100644
index fa49444181f9..000000000000
--- a/10-build-in-src.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/main.go
-+++ b/main.go
-@@ -20,7 +20,7 @@ import (
- "flag"
- "fmt"
-
-- "github.com/ccding/go-stun/stun"
-+ "./stun"
- )
-
- func main() {
diff --git a/PKGBUILD b/PKGBUILD
index d057ac4ac1dc..6caa17d8cd4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,17 @@
# Maintainer: Edward Pacman <edward@edward-p.xyz>
pkgname=go-stun-git
-pkgver=r116.be486d1
+pkgver=r125.d587b28
pkgrel=1
pkgdesc="A go implementation of the STUN client (RFC 3489 and RFC 5389)"
arch=('x86_64')
url="https://github.com/ccding/go-stun"
license=('Apache')
-source=("git+https://github.com/ccding/go-stun.git"
- "10-build-in-src.patch")
+source=("git+https://github.com/ccding/go-stun.git")
makedepends=("go" "git")
provides=(go-stun)
conflicts=(go-stun)
-sha256sums=('SKIP'
- '1cc32a4bace519635092657b861fbf4d02753ec7480790c738f133fba97cc4fd')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/go-stun"
@@ -24,11 +22,6 @@ pkgver() {
}
-prepare(){
- cd "${srcdir}/go-stun"
- patch -Np1 < ../10-build-in-src.patch
-}
-
build(){
cd "${srcdir}/go-stun"
go build