aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornolash2020-02-10 12:05:15 +0100
committernolash2020-02-10 12:05:15 +0100
commitcdcbbea1d021f00ad2f3e940a96710a6734a7dbb (patch)
tree80b5a035251ef21874b48c946b687bbf0efb7ef6
parent81e28fe4cd539f5c6a1088d54f840ff4fd351039 (diff)
downloadaur-cdcbbea1d021f00ad2f3e940a96710a6734a7dbb.tar.gz
Upgrade to 0.5.6
-rw-r--r--.SRCINFO10
-rw-r--r--CHANGELOG_v0.5.6 (renamed from CHANGELOG_v0.5.5)62
-rw-r--r--PKGBUILD6
-rw-r--r--v0.5.5.tar.gz.sigbin566 -> 0 bytes
-rw-r--r--v0.5.6.tar.gz.sigbin0 -> 566 bytes
5 files changed, 69 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9f3f9f70c49..3ae674a57437 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = go-swarm
pkgdesc = Censorship resistant storage and communication infrastructure for a truly sovereign digital society
- pkgver = 0.5.5
+ pkgver = 0.5.6
pkgrel = 1
url = https://swarm.ethereum.org
install = go-swarm.install
- changelog = CHANGELOG_v0.5.5
+ changelog = CHANGELOG_v0.5.6
arch = x86_64
groups = eth-swarm
license = LGPL3
@@ -16,13 +16,13 @@ pkgbase = go-swarm
optdepends = go-ethereum
optdepends = systemd
provides = go-swarm
- source = https://github.com/ethersphere/swarm/archive/v0.5.5.tar.gz
- source = v0.5.5.tar.gz.sig
+ source = https://github.com/ethersphere/swarm/archive/v0.5.6.tar.gz
+ source = v0.5.6.tar.gz.sig
source = swarm-resources.tar.gz
source = swarm-resources.tar.gz.sig
source = README
validpgpkeys = 0826EDA1702D1E87C6E2875121D2E7BB88C2A746
- md5sums = 9f310eda79eb4bfd79bfbebbc9a24555
+ md5sums = 638c6f36b56c5dd836c1af136c002d53
md5sums = SKIP
md5sums = 2fa858d7e4cb420ee9cdf53a33bf0a67
md5sums = SKIP
diff --git a/CHANGELOG_v0.5.5 b/CHANGELOG_v0.5.6
index e87d9f4d4f11..b0f26cfac4f8 100644
--- a/CHANGELOG_v0.5.5
+++ b/CHANGELOG_v0.5.6
@@ -1,4 +1,64 @@
-## v0.5.5 (Unreleased)
+## v0.6.0 (Unreleased)
+
+## v0.5.6 (February 10, 2020)
+
+### Notes
+
+- A hotfix to ENS resolver contract address has been applied due to a security vulnerability. More information here: https://medium.com/the-ethereum-name-service/ens-registry-migration-bug-fix-new-features-64379193a5a
+- A bug related to syncing has been fixed
+
+### Commits
+* [#2021](https://github.com/ethersphere/swarm/pull/2021) bmt: Introduce SectionWriter, implement hash.Hash in bmt
+* [#2096](https://github.com/ethersphere/swarm/pull/2096) Revert "stream: limit the number of peers we sync with on bin 0 (#1972)"
+* [#2095](https://github.com/ethersphere/swarm/pull/2095) stream: fix stream not wanted bug
+* [#2091](https://github.com/ethersphere/swarm/pull/2091) contract/ens: use new ens contract address 0x00000000000C2E074eC69A0dFb2997BA6C7d2e1e
+* [#1983](https://github.com/ethersphere/swarm/pull/1983) swap: prevent debt cheques
+* [#2090](https://github.com/ethersphere/swarm/pull/2090) api/http/langos: fix TestHTTPMultipleRangeResponse test
+* [#2088](https://github.com/ethersphere/swarm/pull/2088) state, swap: add batch support to state store
+
+
+## v0.5.5 (January 29, 2020)
+
+### Notes
+
+- RNS resolution is now available in addition to the existing ENS resolution. See more about RNS here: https://developers.rsk.co/rif/rns
+- Retrieve requests will now load balance across different peers in the address book
+- Retrieve request which were forwarded will now be answered without going through the local store, making retrievals faster
+- New peers will be suggested to connect to by address space gaps
+- Protocol handlers are now async by design
+- Fixes a bug where requested plain hashes would be redundantly sent to ENS resolver
+
+### Commits
+
+* [#2081](https://github.com/ethersphere/swarm/pull/2081) api: do not try to resolve swarm hashes over ens
+* [#2073](https://github.com/ethersphere/swarm/pull/2073) kademlia: use IsSameAs instead of Match for capability index comparison
+* [#2063](https://github.com/ethersphere/swarm/pull/2063) swap, uint256: unify variable types, pt. 1
+* [#2065](https://github.com/ethersphere/swarm/pull/2065) network: Suggest peer by address space gap
+* [#2070](https://github.com/ethersphere/swarm/pull/2070) swarm: simplify network test
+* [#2062](https://github.com/ethersphere/swarm/pull/2062) Protocol async errors refactor
+* [#2074](https://github.com/ethersphere/swarm/pull/2074) swap: move shared test helpers to separate file
+* [#2066](https://github.com/ethersphere/swarm/pull/2066) swap: refactor cashout logic to cashout processor
+* [#2072](https://github.com/ethersphere/swarm/pull/2072) network, storage: fix usage of base logger
+* [#2018](https://github.com/ethersphere/swarm/pull/2018) p2p, network, bzzeth: p2p protocol handlers to async
+* [#2051](https://github.com/ethersphere/swarm/pull/2051) P2p validate accounting
+* [#1981](https://github.com/ethersphere/swarm/pull/1981) network/retrieval: integrate kademlia load balancing
+* [#2064](https://github.com/ethersphere/swarm/pull/2064) tracing: fix Setup function
+* [#2056](https://github.com/ethersphere/swarm/pull/2056) api, cmd/swarm: remove unused cli context from act functions
+* [#2057](https://github.com/ethersphere/swarm/pull/2057) cmd, metrics: decouple metrics and cli library
+* [#2061](https://github.com/ethersphere/swarm/pull/2061) swap: pass depositAmount to testDeploy
+* [#2060](https://github.com/ethersphere/swarm/pull/2060) cmd/swarm, internal/debug: decouple cli library from internal/debug
+* [#2059](https://github.com/ethersphere/swarm/pull/2059) cmd, tracing: decouple cli from tracing package
+* [#2053](https://github.com/ethersphere/swarm/pull/2053) swap: pass the context to waitForTx directly
+* [#2023](https://github.com/ethersphere/swarm/pull/2023) swap: added cheques metrics
+* [#2016](https://github.com/ethersphere/swarm/pull/2016) storage: Preserve counter across Encrypt() calls
+* [#2015](https://github.com/ethersphere/swarm/pull/2015) log, network, storage, testutil: Log base address only in tests
+* [#1999](https://github.com/ethersphere/swarm/pull/1999) storage/localstore: decode tags in push index only if it is complete
+* [#2000](https://github.com/ethersphere/swarm/pull/2000) all:use bzzaddr instead of overlay address for logging
+* [#1982](https://github.com/ethersphere/swarm/pull/1982) netstore: optimize fetchers for retrieve forwarding
+* [#1964](https://github.com/ethersphere/swarm/pull/1964) swap, contracts, vendor: move to ERC20
+* [#2001](https://github.com/ethersphere/swarm/pull/2001) api/http: use swarm.eth instead theswarm.eth in html templates
+* [#2002](https://github.com/ethersphere/swarm/pull/2002) metrics: remove metrics.influxdb.accounting flag
+* [#1939](https://github.com/ethersphere/swarm/pull/1939) swarm, api, main: RNS resolution
## v0.5.4 (November 29, 2019)
diff --git a/PKGBUILD b/PKGBUILD
index 2e777202b528..737a28e4b23a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Louis Holbrook <dev@holbrook.no>
pkgname=go-swarm
-pkgver=0.5.5
+pkgver=0.5.6
pkgrel=1
epoch=
pkgdesc="Censorship resistant storage and communication infrastructure for a truly sovereign digital society"
@@ -18,14 +18,14 @@ replaces=()
backup=()
options=()
install=${pkgname}.install
-changelog="CHANGELOG_v0.5.5"
+changelog="CHANGELOG_v0.5.6"
source=("https://github.com/ethersphere/swarm/archive/v${pkgver}.tar.gz"
"v${pkgver}.tar.gz.sig"
"swarm-resources.tar.gz"
"swarm-resources.tar.gz.sig"
"README")
noextract=()
-md5sums=("9f310eda79eb4bfd79bfbebbc9a24555"
+md5sums=("638c6f36b56c5dd836c1af136c002d53"
"SKIP"
"2fa858d7e4cb420ee9cdf53a33bf0a67"
"SKIP"
diff --git a/v0.5.5.tar.gz.sig b/v0.5.5.tar.gz.sig
deleted file mode 100644
index f3259c408d99..000000000000
--- a/v0.5.5.tar.gz.sig
+++ /dev/null
Binary files differ
diff --git a/v0.5.6.tar.gz.sig b/v0.5.6.tar.gz.sig
new file mode 100644
index 000000000000..8b895804c200
--- /dev/null
+++ b/v0.5.6.tar.gz.sig
Binary files differ