summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Whited2020-01-06 09:07:50 -0500
committerSam Whited2020-01-06 09:07:50 -0500
commitc5c1597a27ba138ca0dc96ce67c6b8265d3bf077 (patch)
tree0131eca1867dfb495f5ed9b5220d40bc55c6e8f5
parent61dcbbf0b80978d1112cb1c4213e905060965bb9 (diff)
downloadaur-c5c1597a27ba138ca0dc96ce67c6b8265d3bf077.tar.gz
Cleanup and minor Go build tweaks
Previously building used some old flags and environment variables that can be simplified or are no longer necessary. This cleans those up and makes the build lines simpler.
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD7
3 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6eb6f3883403..37224560b0ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = go-tools-git
pkgdesc = Developer tools for the Go programming language
- pkgver = v0.0.0_20190826234050_71894ab67ee3
+ pkgver = v0.0.0_20200103221440_774c71fcf114
pkgrel = 1
url = https://godoc.org/golang.org/x/tools/
arch = x86_64
diff --git a/.gitignore b/.gitignore
index 289423078287..9b6c6d993aa6 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,8 @@
go-tools-git/
pkg/
src/
+*.tar
*.tar.gz
*.tar.xz
+*.tar.zstd
*.zip
diff --git a/PKGBUILD b/PKGBUILD
index ade7945a0166..e6159cd0d09c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Egor Kovetskiy <e.kovetskiy@office.ngs.ru>
pkgname=go-tools-git
-pkgver=v0.0.0_20190826234050_71894ab67ee3
+pkgver=v0.0.0_20200103221440_774c71fcf114
pkgrel=1
pkgdesc='Developer tools for the Go programming language'
arch=(x86_64)
@@ -31,18 +31,15 @@ pkgver() {
prepare() {
- export GO111MODULE=on
rm -rf build/
mkdir -p build/
mkdir -p cache/
}
build() {
- export GO111MODULE=on
cd "${pkgname}"
GOCACHE="${srcdir}/cache" GOBIN="${srcdir}/build" go install -v -a \
- -gcflags "all=-trimpath=${PWD}" \
- -asmflags "all=-trimpath=${PWD}" \
+ -trimpath \
-ldflags "-extldflags ${LDFLAGS}" \
-buildmode=pie \
./cmd/...