summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Schneider2016-03-30 18:24:00 +0200
committerSven Schneider2016-03-30 18:24:00 +0200
commita91ad3dbbe3419690b4d9f1977cf2733bb900912 (patch)
treed356ed85f0d1602088955aaa73ec64515eb0878d
downloadaur-a91ad3dbbe3419690b4d9f1977cf2733bb900912.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b5fd32ca720
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Mar 30 14:48:26 UTC 2016
+pkgbase = go-uuid
+ pkgdesc = A pure Go implementation of Universally Unique Identifier (UUID)
+ pkgver = 100.f9ab0dc
+ pkgrel = 1
+ url = https://godoc.org/github.com/satori/go.uuid
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = rsync
+ depends = go
+ options = !strip
+ options = !emptydirs
+
+pkgname = go-uuid
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d29f42162a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Sven Schneider <archlinux.sandmann@googlemail.com>
+
+pkgname=go-uuid
+pkgver=100.f9ab0dc
+pkgrel=1
+pkgdesc="A pure Go implementation of Universally Unique Identifier (UUID)"
+arch=('x86_64' 'i686')
+url="https://godoc.org/github.com/satori/go.uuid"
+license=('MIT')
+depends=('go')
+makedepends=('rsync')
+options=('!strip' '!emptydirs')
+_gourl='github.com/satori/go.uuid'
+
+build() {
+ GOPATH="${srcdir}" go get -v -x ${_gourl}
+}
+
+package() {
+ cd "${srcdir}"
+
+ mkdir -p "${pkgdir}/usr/lib/go"
+ rsync -avz --exclude .git {src,pkg} "${pkgdir}/usr/lib/go"
+
+ install -Dm644 "src/${_gourl}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}