summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2017-03-09 12:24:09 +0100
committerAlexander F Rødseth2017-03-09 12:24:09 +0100
commit0c55efaa576b26a99e3d5017df33059bbbb3bfb6 (patch)
tree3e42e7083023e9405ca39013aa32eb00bed7009f
downloadaur-0c55efaa576b26a99e3d5017df33059bbbb3bfb6.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..afb5d3b92ca1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Mar 9 11:24:03 UTC 2017
+pkgbase = go-xxd
+ pkgdesc = Fast, standalone drop-in replacement for xxd
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/felixge/go-xxd/
+ arch = x86_64
+ arch = i686
+ license = unknown
+ makedepends = go
+ makedepends = git
+ conflicts = vim
+ source = git+https://github.com/felixge/go-xxd#commit=0e80be1
+ md5sums = SKIP
+
+pkgname = go-xxd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..781e85c67d7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+
+pkgname=go-xxd
+pkgver=1.0
+pkgrel=1
+pkgdesc='Fast, standalone drop-in replacement for xxd'
+arch=('x86_64' 'i686')
+url='https://github.com/felixge/go-xxd/'
+license=('unknown')
+makedepends=('go' 'git' )
+conflicts=('vim')
+source=("git+https://github.com/felixge/go-xxd#commit=0e80be1")
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+
+ go build -x
+}
+
+package() {
+ cd "$pkgname"
+
+ install -Dm755 go-xxd "$pkgdir/usr/bin/xxd"
+# install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: