summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Harrison2021-06-15 09:22:18 -0400
committerMatt Harrison2021-06-15 09:22:18 -0400
commit78fcb1a1700e48d71428a63cd52b617913d8c339 (patch)
treeccf6f1f152ea9471f2a5abf21001b330f4deefa6
parentf8be9ea4f72b6e70fcd1839fbb97276523e3a416 (diff)
downloadaur-78fcb1a1700e48d71428a63cd52b617913d8c339.tar.gz
upgpkg: go.rice 1.0.2-1
upstream release Include go build flags
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1818b6fc05a8..d3c168ce2ac2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = go.rice
pkgdesc = Go package that makes working with resources such as html,js,css,images,templates, etc very easy.
- pkgver = 1.0.0
+ pkgver = 1.0.2
pkgrel = 1
url = https://github.com/GeertJohan/go.rice
arch = x86_64
license = BSD
makedepends = go
- source = go.rice-1.0.0.tar.gz::https://github.com/GeertJohan/go.rice/archive/v1.0.0.tar.gz
- sha256sums = 540cb64258fc2422664c73454b5dbaac5487a45906c935d25285a2a60085d877
+ depends = glibc
+ source = go.rice-1.0.2.tar.gz::https://github.com/GeertJohan/go.rice/archive/v1.0.2.tar.gz
+ sha256sums = 2eed960aa9531a87c82d2379677723bc0129bc9e387dc0dbb3bb70b78c928dd0
pkgname = go.rice
-
diff --git a/PKGBUILD b/PKGBUILD
index e29687705c9e..19059b157d16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,24 @@
# Maintainer: Matt Harrison <matt@harrison.us.com>
pkgname=go.rice
-pkgver=1.0.0
+pkgver=1.0.2
pkgrel=1
pkgdesc='Go package that makes working with resources such as html,js,css,images,templates, etc very easy.'
arch=(x86_64)
url='https://github.com/GeertJohan/go.rice'
license=("BSD")
+depends=(glibc)
makedepends=(go)
source=("$pkgname-$pkgver.tar.gz::https://github.com/GeertJohan/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('540cb64258fc2422664c73454b5dbaac5487a45906c935d25285a2a60085d877')
+sha256sums=('2eed960aa9531a87c82d2379677723bc0129bc9e387dc0dbb3bb70b78c928dd0')
build() {
cd "$srcdir/$pkgname-$pkgver/rice"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
go build -a
}