summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Harrison2020-01-27 15:21:16 -0500
committerMatt Harrison2020-01-27 15:21:16 -0500
commitee11f142dbe4f55e14e4f477562367d89a2f2256 (patch)
tree61da3cae6b9807617aef491f756004464a9d10fd
downloadaur-ee11f142dbe4f55e14e4f477562367d89a2f2256.tar.gz
Initial upload: go.rice 1.0.0-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d563693ea32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = go.rice
+ pkgdesc = Go package that makes working with resources such as html,js,css,images,templates, etc very easy.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://statping.com/
+ arch = x86_64
+ license = BSD
+ makedepends = go
+ source = go.rice-1.0.0.tar.gz::https://github.com/GeertJohan/go.rice/archive/v1.0.0.tar.gz
+ sha256sums = 540cb64258fc2422664c73454b5dbaac5487a45906c935d25285a2a60085d877
+
+pkgname = go.rice
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb1b4be6d5a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Matt Harrison <matt@harrison.us.com>
+
+pkgname=go.rice
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Go package that makes working with resources such as html,js,css,images,templates, etc very easy.'
+arch=(x86_64)
+url='https://statping.com/'
+license=("BSD")
+makedepends=(go)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/GeertJohan/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('540cb64258fc2422664c73454b5dbaac5487a45906c935d25285a2a60085d877')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver/rice"
+ go build -a
+}
+
+package() {
+ install -D -m 0755 "$srcdir/$pkgname-$pkgver/rice/rice" "$pkgdir/usr/bin/rice"
+ install -Dm644 "$srcdir/$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}