summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Rammhold2016-06-09 22:36:20 +0200
committerAndreas Rammhold2016-06-09 22:36:20 +0200
commit03ece3954cff475d8eee4df322c25400120c9d81 (patch)
tree4dbb7e4874883acc4c0fae3fd4487cf50273a807
downloadaur-03ece3954cff475d8eee4df322c25400120c9d81.tar.gz
Initial super version
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa7a4be56073
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = go3status
+ pkgver = 0.0.42
+ pkgrel = 1
+ url = https://github.com/andir/go3status
+ arch = x86_64
+ arch = i686
+ license = GPLv3
+ makedepends = go
+ options = !strip
+
+pkgname = go3status
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3576c885f9c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer Andreas Rammhold <andreas@rammhold.de>
+
+pkgname=go3status
+pkgver=0.0.42
+pkgrel=1
+pgdesc="Awesome i3bar tool"
+arch=('x86_64' 'i686')
+url='https://github.com/andir/go3status'
+license=('GPLv3')
+makedepends=('go')
+options=('!strip')
+_gourl="github.com/andir/go3status"
+
+build() {
+ GOPATH="${srcdir}" go get -v -x ${_gourl}
+}
+
+
+package() {
+ cd "${srcdir}"
+ mkdir -p "${pkgdir}/usr/bin/"
+ install -m 655 "bin/go3status" "${pkgdir}/usr/bin/go3status"
+}
+