summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorL.G. Sarmiento2018-08-03 12:28:00 +0200
committerL.G. Sarmiento2018-08-03 12:28:00 +0200
commit3fc6684e68932da540b1448f8eff9876906baaa1 (patch)
treefeb5e898c65b7577f9978f703849e86c7df71bd9
parentfbf0fa3c75fa13c530b9ed24a08d22364ca82920 (diff)
downloadaur-3fc6684e68932da540b1448f8eff9876906baaa1.tar.gz
now uses Qt4 and compiles with c++17 as ROOT
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD35
2 files changed, 8 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d6aeb590bc6..b18626ad6d19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
# Generated by mksrcinfo v8
-# Fri Mar 23 19:05:10 UTC 2018
+# Fri Aug 3 10:27:10 UTC 2018
pkgbase = go4
pkgdesc = Object-oriented system (GSI Object Oriented On-line Off-line system) based on ROOT
pkgver = 5.3.0
- pkgrel = 8
+ pkgrel = 9
url = https://www.gsi.de/en/work/research/electronics/data_processing/data_analysis/the_go4_home_page.htm
arch = x86_64
license = GPL
depends = root
- depends = qt5-base
+ depends = qt4
source = http://web-docs.gsi.de/~go4/download/go4-5.3.0.tar.gz
md5sums = 30d375a46fd5a1f13a15914eeec5629c
diff --git a/PKGBUILD b/PKGBUILD
index 58c6a1e00899..5b767c53ea7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,15 @@
# Contributor: Luis Sarmiento < Luis.Sarmiento-ala-nuclear.lu.se >
#
-# Note to self. It is necessary to remove the current Go4 installation -if any- otherwise the compilation fails.
-# Also, after removal, use a fresh terminal as go4login variables are no longer valid
-# Maybe just unsetting GO4SYS is enough(?) [looks like it is]
-#
# It looks that ROOT6 requires the modification/definition of the variable ROOT_INCLUDE_PATH to /usr/include/go4
+# so we do this at the /etc/profile.d/go4.sh file.
#
pkgname=go4
_Pkgname=Go4
pkgver=5.3.0
-pkgrel=8
+pkgrel=9
pkgdesc='Object-oriented system (GSI Object Oriented On-line Off-line system) based on ROOT'
arch=('x86_64')
-depends=('root' 'qt5-base')
+depends=('root' 'qt4')
url="https://www.gsi.de/en/work/research/electronics/data_processing/data_analysis/the_go4_home_page.htm"
license=('GPL')
source=("http://web-docs.gsi.de/~go4/download/go4-${pkgver}.tar.gz")
@@ -30,21 +27,7 @@ prepare() {
sed -i 's#\$(GO4LIBPATH)#$(DESTDIR)/&#g' Makefile
sed -i 's#\$(GO4TOPPATH)#$(DESTDIR)/&#g' Makefile
- #/usr/include/root/Riosfwd.h:25:2: warning:
- #warning "Riosfwd.h is deprecated. It will be removed in ROOT v6.12. Please use #include <iosfwd>, instead."
- #msg "Go4 5.2.0 needs fixing lack of Riosfwd.h from ROOT 6.12"
- #sed -i 's/#include "Riosfwd.h"/#include <iosfwd>/g' Go4EventServer/TGo4MbsFile.cxx
- #
- # this was fixed in 5.3.0
- #
- # #include "RVersion.h"
- # #if ROOT_VERSION_CODE <= ROOT_VERSION(6,8,0)
- # #include "Riosfwd.h"
- # #else
- # #include <iosfwd>
- # #endif
- #
-
+ sed -i 's#QMAKE_CXXFLAGS=#& -std=c++17#g' Makefile.config
}
build() {
@@ -56,15 +39,7 @@ build() {
##
# rpath=false seemed to reduce que volume of warnings with ROOT6
##
- ##
- # go4 does NOT compile unless you compile ROOT with
- #
- # set (cxx14 ON CACHE BOOL "" FORCE)
- # instead of
- # set (cxx17 ON CACHE BOOL "" FORCE)
- # in setting.cmake <-- ROOT package
- ##
- make prefix=/usr withqt=5 GO4_OS=Linux rpath=false withdabc=yes nodepend=1 debug=1 all || return 1
+ make prefix=/usr withqt=4 GO4_OS=Linux rpath=false withdabc=yes nodepend=1 debug=1 all || return 1
}