summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorL.G. Sarmiento2021-04-30 18:07:49 +0200
committerL.G. Sarmiento2021-04-30 18:07:49 +0200
commita716f38015bd2a1721390568684a277ccc336d4c (patch)
treec8a2ff4e0061e0e08ff293e47a6c05f622364b98
parent8ff08e036cf4b5c17cdb5d0f328ff58935a86e49 (diff)
downloadaur-a716f38015bd2a1721390568684a277ccc336d4c.tar.gz
as of April 30, 2021
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 81ca718219b1..5be63e2659df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,6 +28,7 @@ prepare() {
sed -i 's#\$(GO4TOPPATH)#$(DESTDIR)/&#g' Makefile
# something change and the libraries are not found now at compilation time
+ # works in combination to NOT having go4 already installed in the system
patch -Np2 < ${srcdir}/Makefile.config.patch
# gSystem not found
@@ -37,6 +38,9 @@ prepare() {
sed -i '1s;^;#include <TDatime.h>\n;' Go4ConditionsBase/TGo4Condition.cxx
sed -i '1s;^;#include <TDatime.h>\n;' Go4AnalysisClient/TGo4AnalysisClientImp.cxx
+ # error: field ... has incomplete type ‘TString’
+ sed -i '1s;^;#include "TString.h"\n;' Go4ConditionsBase/TGo4Marker.h
+
# error: incomplete type ‘TF1’ used in nested name specifier
sed -i 's;#include "TLatex.h";&\n#include "TF1.h";g' Go4Proxies/TGo4BrowserProxy.cxx
sed -i 's;#include "TLatex.h";&\n#include "TF1.h";g' qt4/Go4GUI/TGo4ViewPanel.cpp
@@ -49,6 +53,10 @@ prepare() {
# error: invalid use of incomplete type ‘class TObjString’
sed -i '1s;^;#include "TObjString.h"\n;' qt4/Go4QtRoot/QRootCanvas.cpp
+
+ # error: invalid use of incomplete type ‘class TCanvasImp’
+ sed -i '1s;^;#include "TCanvasImp.h"\n;' qt4/Go4GUI/TGo4ViewPanel.cpp
+
}
build() {
@@ -58,7 +66,7 @@ build() {
make clean
make prefix=/usr \
- withqt=4 \
+ withqt=5 \
GO4_OS=Linux \
rpath=true \
withdabc=yes \