summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorL.G. Sarmiento2017-06-15 17:47:40 +0200
committerL.G. Sarmiento2017-06-15 17:47:40 +0200
commitcffc3158136ad9694113b0e8f358c5d1ff0a4bac (patch)
treeeabc268676305acddf7c1d0c520928daedd7937e
parent9ad654da5c728e3f71b8f443c5e9d3272b65c8d9 (diff)
downloadaur-cffc3158136ad9694113b0e8f358c5d1ff0a4bac.tar.gz
fixed ROOT_INCLUDE_PATH
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 798d1a3a02c1..8087c674553f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Apr 4 14:49:05 UTC 2017
+# Thu Jun 15 15:47:09 UTC 2017
pkgbase = go4
pkgdesc = Object-oriented system (GSI Object Oriented On-line Off-line system) based on ROOT
pkgver = 5.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.gsi.de/en/work/research/electronics/data_processing/data_analysis/the_go4_home_page.htm
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index b9ce9fde1ce3..b1c3c4e7ade2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,14 @@
# Contributor: Luis Sarmiento < Luis.Sarmiento-ala-nuclear.lu.se >
#
# Note to self. It is necessary to remove the current Go4 installation -if any- otherwise the compilation fails.
+# As of 5.2.0-2 it seems like this is no longer the case
+#
+# It looks that ROOT6 requires the modification/definition of the variable ROOT_INCLUDE_PATH to /usr/include/go4
#
pkgname=go4
_Pkgname=Go4
pkgver=5.2.0
-pkgrel=1
+pkgrel=2
pkgdesc='Object-oriented system (GSI Object Oriented On-line Off-line system) based on ROOT'
arch=('i686' 'x86_64')
depends=('root' 'qt4')
@@ -63,4 +66,12 @@ package() {
" > $srcdir/$pkgname.desktop
install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ ## new ROOT_INCLUDE_PATH definition
+ install -d ${pkgdir}/etc/profile.d
+ echo 'export ROOT_INCLUDE_PATH=$ROOT_INCLUDE_PATH:/usr/include/go4' > ${srcdir}/go4.sh
+ echo 'setenv ROOT_INCLUDE_PATH $ROOT_INCLUDE_PATH:/usr/include/go4' > ${srcdir}/go4.csh
+
+ install -m755 ${srcdir}/go4.sh ${pkgdir}/etc/profile.d/go4.sh
+ install -m755 ${srcdir}/go4.csh ${pkgdir}/etc/profile.d/go4.csh
+
}