summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorL.G. Sarmiento2020-11-04 11:02:10 +0100
committerL.G. Sarmiento2020-11-04 11:02:10 +0100
commit7d3ff5118f4ddb13135883b933c02fc6fb1d86bf (patch)
tree4649d74ada6485f56d4b3dea16a25282a2abc0f5
downloadaur-7d3ff5118f4ddb13135883b933c02fc6fb1d86bf.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD94
2 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..885706888f78
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Nov 4 10:02:02 UTC 2020
+pkgbase = go4-git
+ pkgdesc = Object-oriented system (GSI Object Oriented On-line Off-line system) based on ROOT
+ pkgver = r2054.111adfd6
+ pkgrel = 1
+ url = https://www.gsi.de/en/work/research/experiment_electronics/data_processing/data_analysis/the_go4_home_page.htm
+ arch = x86_64
+ license = GPL
+ depends = root
+ depends = qt5-base
+ provides = go4
+ conflicts = go4
+ source = go4::git+https://github.com/linev/go4.git
+ sha256sums = SKIP
+
+pkgname = go4-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d0efa3b09ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,94 @@
+# Contributor: Luis Sarmiento < Luis.Sarmiento-ala-nuclear.lu.se >
+#
+#
+pkgname=go4-git
+_pkgname=go4
+pkgver=r2054.111adfd6
+pkgrel=1
+pkgdesc='Object-oriented system (GSI Object Oriented On-line Off-line system) based on ROOT'
+arch=('x86_64')
+depends=('root' 'qt5-base')
+url="https://www.gsi.de/en/work/research/experiment_electronics/data_processing/data_analysis/the_go4_home_page.htm"
+license=('GPL')
+source=($_pkgname::git+https://github.com/linev/go4.git)
+sha256sums=('SKIP')
+provides=(go4)
+conflicts=(go4)
+
+pkgver() {
+ cd ${srcdir}/$_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+
+ rm -rf ${srcdir}/build
+ [[ -d ${srcdir}/build ]] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ sed -i 's#$ENV{ROOTSYS}#/usr/lib/cmake/ROOT#g' ${srcdir}/${_pkgname}/cmake/modules/Go4Configuration.cmake
+
+ # with Qt5 there is a change in path for some components
+ find ${srcdir}/${_pkgname}/qt4/Go4GUI -type f -exec sed -e 's#QtGui/QAction#QtWidgets/QApplication#g' -i {} \;
+ find ${srcdir}/${_pkgname}/qt4/Go4GUI -type f -exec sed -e 's#QtGui/QApplication#QtWidgets/QApplication#g' -i {} \;
+
+ cmake -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr \
+ -DGO4PREFIX=/usr \
+ -DROOTSYS=/usr \
+ -DGO4_OS=Linux \
+ -DWITHQT=5 \
+ -Dwithdabc=yes \
+ ${srcdir}/go4
+
+ # -Ddesigner=ON
+
+}
+
+build() {
+ cd ${srcdir}/build
+
+ make all || return 1
+
+}
+
+package() {
+
+ #install the package
+ cd ${srcdir}/build
+ make install
+
+ #install the license
+ install -Dm644 "Go4License.txt" "$pkgdir/usr/share/licenses/go4/Go4License.txt"
+
+ #install the desktop file
+ echo "
+ [Desktop Entry]
+ Name=${_PKGNAME}
+ Comment=${pkgdesc}
+ Exec=go4
+ Icon=xchm-32
+ Terminal=false
+ Type=Application
+ Categories=Utility;Science;
+ StartupNotify=false
+ " > $srcdir/$pkgname.desktop
+ install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+
+ install -d ${pkgdir}/etc/profile.d
+
+ cat <<- EOF > ${srcdir}/go4.sh
+ # source go4login script
+ source /usr/bin/go4login
+
+ # If ROOT_INCLUDE_PATH already exists, then add Go4 to it, otherwise do nothing
+ export ROOT_INCLUDE_PATH=\${ROOT_INCLUDE_PATH:+\$ROOT_INCLUDE_PATH:/usr/include/go4}
+
+ # if ROOT_INCLUDE_PATH does not exist, define it as the one from Go4, otherwise do nothing
+ export ROOT_INCLUDE_PATH=\${ROOT_INCLUDE_PATH:-/usr/include/go4}
+
+EOF
+
+ install -m755 ${srcdir}/go4.sh ${pkgdir}/etc/profile.d/go4.sh
+
+ # Csh no longer supported. Go4 itself does not seem to support it.
+}