summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhashworks2018-09-21 13:25:04 +0200
committerhashworks2018-09-21 13:25:04 +0200
commitd0a9e25e0a994d293c3d4ba7f53a39ebaa24e7bd (patch)
treeb6df44b0870cc15e9c1091f0739f3ede581cbc4a
downloadaur-d0a9e25e0a994d293c3d4ba7f53a39ebaa24e7bd.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04cd9ae50b76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = goaccess-git
+ pkgdesc = GoAccess is a real-time web log analyzer and interactive viewer that runs in a terminal in *nix systems or through your browser.
+ pkgver = r2768.2789816
+ pkgrel = 1
+ url = https://goaccess.io
+ arch = any
+ license = MIT
+ depends = ncurses
+ provides = goaccess
+ conflicts = goaccess
+ backup = etc/goaccess.conf
+ source = git+https://github.com/allinurl/goaccess.git
+ md5sums = SKIP
+
+pkgname = goaccess-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd06824f732c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: hashworks <mail@hashworks.net>
+
+pkgname=goaccess-git
+pkgrel=1
+pkgver=r2768.2789816
+pkgdesc='GoAccess is a real-time web log analyzer and interactive viewer that runs in a terminal in *nix systems or through your browser.'
+url='https://goaccess.io'
+license=('MIT')
+arch=('any')
+conflicts=('goaccess')
+provides=('goaccess')
+depends=('ncurses')
+optdepends==('geoip: Provides a mmdb geoip database')
+backup=('etc/goaccess.conf')
+source=('git+https://github.com/allinurl/goaccess.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "goaccess"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "goaccess"
+ autoreconf -fiv
+ ./configure --prefix="$pkgdir/usr" --enable-utf8 --enable-geoip=mmdb
+ make
+ make sysconfdir="$pkgdir/etc" install
+}