summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsg3des2024-02-17 15:07:56 +0300
committersg3des2024-02-17 15:07:56 +0300
commit1771310b1d33a9c161553610836f6e54033f2b93 (patch)
tree0d1ffe8db28c45ce8031b9c6fcd0eac864a18ffa
parente55598309831d12c464b98e3692fe9460034a538 (diff)
downloadaur-1771310b1d33a9c161553610836f6e54033f2b93.tar.gz
fix PKGBUILD
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD29
2 files changed, 9 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06d31823aad8..6fe774041d7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Feb 4 20:04:47 UTC 2017
pkgbase = goatee
pkgdesc = lightwieght gtk2 text/hex editor written on Go
- pkgver = 0.9
+ pkgver = 0.9.1
pkgrel = 4
url = https://github.com/sg3des/goatee
arch = i686
@@ -12,8 +10,7 @@ pkgbase = goatee
makedepends = go
depends = gtk2
depends = gtksourceview2
- source = git://github.com/sg3des/goatee.git
+ source = git+https://github.com/sg3des/goatee.git
md5sums = SKIP
pkgname = goatee
-
diff --git a/PKGBUILD b/PKGBUILD
index 20f169e59a88..271fc8c44114 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
+# Maintainer: sg3des <sg3des@gmail.com>
# Contributor: sg3des <sg3des@gmail.com>
pkgname=goatee
-pkgver=0.9
+pkgver=0.9.1
pkgrel=4
pkgdesc='lightwieght gtk2 text/hex editor written on Go'
arch=('i686' 'x86_64')
@@ -9,33 +10,17 @@ url='https://github.com/sg3des/goatee'
license=('GPL')
depends=('gtk2' 'gtksourceview2')
makedepends=('git' 'go')
-source=("git://github.com/sg3des/goatee.git")
+source=("git+https://github.com/sg3des/goatee.git")
md5sums=('SKIP')
-build() {
- echo $srcdir
-
- export GOPATH="$srcdir"
- mkdir -p $GOPATH/src/github.com/sg3des
- rm -rf $GOPATH/src/github.com/sg3des/$pkgname
- mv $srcdir/$pkgname $GOPATH/src/github.com/sg3des/
-
-
- cd $GOPATH/src/github.com/sg3des/$pkgname
-
- mkdir -p vendor/github.com/mattn
- cd vendor/github.com/mattn
- git clone https://github.com/sg3des/go-gtk
-
- cd $GOPATH/src/github.com/sg3des/$pkgname
-
- go get -v ./...
- go build -v -o $pkgname
+build() {
+ cd $srcdir/$pkgname
+ go build -v -o $pkgname -ldflags="-s -w" -trimpath
}
package() {
- cd "$GOPATH/src/github.com/sg3des/$pkgname"
+ cd $srcdir/$pkgname
install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
install -Dm755 $pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
} \ No newline at end of file