summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormh4ckt3mh4ckt1c4s2022-10-12 15:22:34 +0200
committermh4ckt3mh4ckt1c4s2022-10-12 15:22:34 +0200
commitd8353e2952d23a347f4cb67e4542897ae7ffea94 (patch)
tree9f22b3bf9644fefffb7b21b19be1373cfc870312
parent862b43aa9edf9240eebeca0ca263ee92c8984ed6 (diff)
downloadaur-d8353e2952d23a347f4cb67e4542897ae7ffea94.tar.gz
Bump to v3.2.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c989e3fe2fd..1bcf3d3f204e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = gobuster-bin
pkgdesc = A Directory/File, DNS and VHost busting tool
- pkgver = 3.1.0
+ pkgver = 3.2.0
pkgrel = 1
url = https://github.com/OJ/gobuster
arch = x86_64
license = Apache
- depends = p7zip
provides = gobuster
conflicts = gobuster
conflicts = gobuster-git
- source_x86_64 = gobuster-3.1.0-1.7z::https://github.com/OJ/gobuster/releases/download/v3.1.0/gobuster-linux-amd64.7z
- sha256sums_x86_64 = 7f11cba97772ac4f276177d5d782e6ebda58fbdbbbf959d6cb02e0454bc52e14
+ source_x86_64 = gobuster-3.2.0-1.tar.gz::https://github.com/OJ/gobuster/releases/download/v3.2.0/gobuster_3.2.0_Linux_x86_64.tar.gz
+ sha256sums_x86_64 = 7c2e410580203f2e5ca1590f79083aaf551342193dfb39ff3e15a65ed889405a
pkgname = gobuster-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 7f39dbb590ba..83184322856b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,23 @@
maintainer=mh4ckwascut
pkgname_orig=gobuster
pkgname=gobuster-bin
-pkgver=3.1.0
+pkgver=3.2.0
pkgrel=1
pkgdesc="A Directory/File, DNS and VHost busting tool"
arch=('x86_64')
url="https://github.com/OJ/gobuster"
provides=('gobuster')
license=('Apache')
-depends=('p7zip')
conflicts=('gobuster' 'gobuster-git')
binname=${pkgname_orig}-${pkgver}-${pkgrel}
-dirname=${pkgname_orig}-linux-amd64
+dirname=${pkgname_orig}_${pkgver}_Linux_x86_64
source_x86_64=(
- "${binname}.7z::${url}/releases/download/v${pkgver}/${dirname}.7z"
+ "${binname}.tar.gz::${url}/releases/download/v${pkgver}/${dirname}.tar.gz"
)
sha256sums_x86_64=(
- '7f11cba97772ac4f276177d5d782e6ebda58fbdbbbf959d6cb02e0454bc52e14'
+ '7c2e410580203f2e5ca1590f79083aaf551342193dfb39ff3e15a65ed889405a'
)
package(){
- 7z x "${binname}.7z"
- install -Dm755 "${dirname}/${pkgname_orig}" "$pkgdir/usr/bin/${pkgname_orig}"
+ install -Dm755 "${pkgname_orig}" "$pkgdir/usr/bin/${pkgname_orig}"
}