summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Tompkins2018-06-10 10:33:57 -0400
committerMark Tompkins2018-06-10 10:33:57 -0400
commitcee4e5c1b85739886c5df90dd069f2d7169a9e4a (patch)
tree439104971edb7351696bee4b5020c7f716ef1da8
downloadaur-cee4e5c1b85739886c5df90dd069f2d7169a9e4a.tar.gz
Init gobyte-qt repo
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD33
-rw-r--r--gobyte-qt.desktop11
-rw-r--r--gobyte-qt.install11
5 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5123f988aca7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = gobyte-qt
+ pkgdesc = Cryptocurrency wallet(QT)
+ pkgver = 0.12.2
+ pkgrel = 3
+ url = https://www.gobyte.network/
+ install = gobyte-qt.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = boost
+ makedepends = qt5-tools
+ depends = boost-libs
+ depends = qt5-base
+ depends = qrencode
+ depends = miniupnpc
+ depends = db4.8
+ depends = zeromq
+ depends = protobuf
+ depends = libevent
+ conflicts = gobyte
+ source = gobyte-qt::git+https://github.com/gobytecoin/gobyte.git
+ source = gobyte-qt.desktop
+ sha256sums = SKIP
+ sha256sums = cfedcb808ba80d55409394db7483709daac526b351ceada402588dab3a83d84b
+
+pkgname = gobyte-qt
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1e2b0c0734b7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81fd170adcfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: metscoin <mets_coin@outlook.com>
+
+pkgname=gobyte-qt
+pkgver=0.12.2
+pkgrel=3
+arch=('i686' 'x86_64')
+url="https://www.gobyte.network/"
+license=('MIT')
+pkgdesc="Cryptocurrency wallet(QT)"
+depends=(boost-libs qt5-base qrencode miniupnpc db4.8 zeromq protobuf libevent)
+makedepends=(boost qt5-tools)
+conflicts=(gobyte)
+install=gobyte-qt.install
+source=("${pkgname%-git}::git+https://github.com/gobytecoin/gobyte.git"
+ "$pkgname.desktop")
+sha256sums=('SKIP'
+ 'cfedcb808ba80d55409394db7483709daac526b351ceada402588dab3a83d84b')
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./autogen.sh
+ ./configure --with-gui=qt5
+ make
+}
+
+
+package() {
+ install -Dm644 gobyte-qt.desktop "$pkgdir"/usr/share/applications/gobyte.desktop
+ cd "$srcdir/$pkgname"
+ install -Dm755 src/qt/gobyte-qt "$pkgdir"/usr/bin/gobyte-qt
+ install -Dm644 share/pixmaps/gobyte128.png "$pkgdir"/usr/share/pixmaps/gobyte128.png
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
diff --git a/gobyte-qt.desktop b/gobyte-qt.desktop
new file mode 100644
index 000000000000..5a8d4eb70f4b
--- /dev/null
+++ b/gobyte-qt.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=GoBtye
+Comment=GoByte P2P Cryptocurrency
+Exec=/usr/bin/gobyte-qt
+Terminal=false
+Type=Application
+Icon=/usr/share/pixmaps/gobyte128.png
+MimeType=x-scheme-handler/gobyte;
+Categories=Office;
+Name[en_US]=gobyte-qt.desktop
diff --git a/gobyte-qt.install b/gobyte-qt.install
new file mode 100644
index 000000000000..f98ba7338938
--- /dev/null
+++ b/gobyte-qt.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}