summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-03-16 07:17:48 +0200
committerDimitris Kiziridis2020-03-16 07:17:48 +0200
commit2a03853751a9715baa0c07c1f1a723d075b2be9f (patch)
treeac61e43a5779c11356942a6097ca8f64b2d41656
downloadaur-2a03853751a9715baa0c07c1f1a723d075b2be9f.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f4d8ef9cd38
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gocity
+ pkgdesc = Code City metaphor for visualizing Go source code in 3D
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://go-city.github.io
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ provides = gocity
+ source = gocity-1.0.0.tar.gz::https://github.com/rodrigo-brito/gocity/archive/v1.0.0.tar.gz
+ md5sums = 7387d4727740f49f374d91aea14d7b43
+
+pkgname = gocity
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47ab331a403e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=gocity
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Code City metaphor for visualizing Go source code in 3D"
+arch=('x86_64')
+url='https://go-city.github.io'
+license=('MIT')
+provides=('gocity')
+makedepends=('go')
+source=("gocity-${pkgver}.tar.gz::https://github.com/rodrigo-brito/gocity/archive/v${pkgver}.tar.gz")
+md5sums=('7387d4727740f49f374d91aea14d7b43')
+
+build() {
+ cd "${srcdir}/gocity-${pkgver}"
+ mkdir -p $srcdir/go
+ export GOPATH="${srcdir}"/go
+ export PATH=$PATH:$GOPATH/bin
+ cd "${srcdir}/gocity-${pkgver}"
+ go build -v -o "../gocity-bin"
+}
+
+package() {
+ cd "${srcdir}/gocity-${pkgver}"
+ install -Dm755 ../gocity-bin "${pkgdir}/usr/bin/gocity"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/gocity/LICENSE"
+ go clean -modcache #Remove go libraries
+} \ No newline at end of file