summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-05-27 14:11:23 +0200
committerGoliathLabs2020-05-27 14:11:23 +0200
commit2d493621156fc2452795b78f44c48c5188d856ca (patch)
tree8617bd6af73b463aed572ccb2e1d315b7c900ec8
parent2055421fe268b1c2abf69f753ccbf4f7a0b9ad0a (diff)
downloadaur-2d493621156fc2452795b78f44c48c5188d856ca.tar.gz
Updated: PKGBUILD
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD33
2 files changed, 24 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2aa10573001c..d5f6415e3f9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gocode-git
pkgdesc = An autocompletion daemon for the Go programming language
- pkgver = 637.10c1e59
+ pkgver = r785.5bee97b
pkgrel = 1
url = https://github.com/nsf/gocode
arch = i686
@@ -8,9 +8,9 @@ pkgbase = gocode-git
license = MIT
makedepends = git
depends = go
- optdepends = auto-complete: emacs autocompletion
- source = git+https://github.com/nsf/gocode
- md5sums = SKIP
+ conflicts = liteide
+ source = git+https://github.com/nsf/gocode.git
+ sha256sums = SKIP
pkgname = gocode-git
diff --git a/PKGBUILD b/PKGBUILD
index f77b094771d4..48ce9065cafd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,12 @@
-# Maintainer: yesuu zhang <yesuu79@qq.com>
+# Maintainer:
+# Contributor: Felix Golatofski <contact@xdfr.de>
+# Contributor: yesuu zhang <yesuu79@qq.com>
# Contributor: Daniel YC Lin <dlin.tw at> gmail.com>
# Contributor: Daniel Micay <danielmicay@gmail.com>
# Contributor: Dave Reisner <d@falconindy.com>
pkgname=gocode-git
-pkgver=637.10c1e59
+pkgver=r785.5bee97b
pkgrel=1
pkgdesc="An autocompletion daemon for the Go programming language"
arch=('i686' 'x86_64')
@@ -12,20 +14,25 @@ url="https://github.com/nsf/gocode"
license=('MIT')
depends=('go')
makedepends=('git')
-optdepends=('auto-complete: emacs autocompletion')
-source=('git+https://github.com/nsf/gocode')
-md5sums=('SKIP')
+source=('git+https://github.com/nsf/gocode.git')
+conflicts=('liteide')
+sha256sums=('SKIP')
+pkgver() {
+ cd "$srcdir/gocode"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
build() {
- cd "${srcdir}/gocode"
- go build -o gocode
+ cd "${srcdir}/gocode"
+ go build -o gocode
}
package() {
- cd "${srcdir}/gocode"
- install -Dm755 gocode "${pkgdir}/usr/bin/gocode"
- install --directory "${pkgdir}/usr/share/vim/vimfiles"
- cp -r vim/autoload "${pkgdir}/usr/share/vim/vimfiles"
- cp -r vim/ftplugin "${pkgdir}/usr/share/vim/vimfiles"
- install -Dm644 emacs/go-autocomplete.el "${pkgdir}/usr/share/emacs/site-lisp/go-autocomplete.el"
+ cd "${srcdir}/gocode"
+ install -Dm755 gocode "${pkgdir}/usr/bin/gocode"
+ install --directory "${pkgdir}/usr/share/vim/vimfiles"
+ cp -r vim/autoload "${pkgdir}/usr/share/vim/vimfiles"
+ cp -r vim/ftplugin "${pkgdir}/usr/share/vim/vimfiles"
+ install -Dm644 emacs/go-autocomplete.el "${pkgdir}/usr/share/emacs/site-lisp/go-autocomplete.el"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/gocode/LICENSE"
}