summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpetres2016-06-10 11:16:30 +0200
committerpetres2016-06-10 11:16:30 +0200
commit7db7d76954f2640efffaf6bb91f74fd94820884d (patch)
tree6b76d3f8720604d656e312194ad6607567994a49
parent65374fd4a25128b6bb55bae07622274f63e60550 (diff)
downloadaur-7db7d76954f2640efffaf6bb91f74fd94820884d.tar.gz
new version and including man page
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--gocryptfs.1197
3 files changed, 209 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23b80ad4291b..5b22a4c0b8f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue May 31 12:03:52 UTC 2016
+# Fri Jun 10 09:15:33 UTC 2016
pkgbase = gocryptfs
pkgdesc = Encrypted overlay filesystem written in Go.
- pkgver = 0.10_release
+ pkgver = 0.11
pkgrel = 1
url = https://github.com/rfjakob/gocryptfs
arch = i686
@@ -11,8 +11,10 @@ pkgbase = gocryptfs
makedepends = git
makedepends = go
depends = gcc-libs>=5.3.0-3 openssl
- source = git+https://github.com/rfjakob/gocryptfs.git#tag=v0.10
+ source = git+https://github.com/rfjakob/gocryptfs.git#tag=v0.11
+ source = gocryptfs.1
md5sums = SKIP
+ md5sums = d9d3ea3e1ecfa367d318523fa7e1e65f
pkgname = gocryptfs
diff --git a/PKGBUILD b/PKGBUILD
index d19c40730576..024dafb1d992 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Peter Reschenhofer <peter.reschenhofer@gmail.com>
pkgname=gocryptfs
-pkgver=0.10_release
-_tag=v0.10
+pkgver=0.11
+_tag=v0.11
pkgrel=1
pkgdesc="Encrypted overlay filesystem written in Go."
arch=('i686' 'x86_64')
@@ -9,8 +9,10 @@ url="https://github.com/rfjakob/gocryptfs"
license=('MIT')
depends=('gcc-libs>=5.3.0-3 openssl')
makedepends=('git' 'go')
-source=("git+https://github.com/rfjakob/gocryptfs.git#tag=$_tag")
-md5sums=('SKIP')
+source=("git+https://github.com/rfjakob/gocryptfs.git#tag=$_tag"
+ "gocryptfs.1")
+md5sums=('SKIP'
+ 'd9d3ea3e1ecfa367d318523fa7e1e65f')
prepare() {
export GOPATH="$PWD/GO"
@@ -26,4 +28,5 @@ build() {
package() {
install -Dm755 "$PWD/GO/bin/gocryptfs" "$pkgdir/usr/bin/gocryptfs"
+ install -Dm644 "gocryptfs.1" "$pkgdir/usr/share/man/man1/gocryptfs.1"
}
diff --git a/gocryptfs.1 b/gocryptfs.1
new file mode 100644
index 000000000000..c338fff8335c
--- /dev/null
+++ b/gocryptfs.1
@@ -0,0 +1,197 @@
+.\" Automatically generated by Pandoc 1.17.0.3
+.\"
+.TH "GOCRYPTFS" "1" "May 2016" "" ""
+.hy
+.SH NAME
+.PP
+gocryptfs \- mount an encrypted directory
+.SH SYNOPSIS
+.SS Initialize encrypted filesystem
+.PP
+gocryptfs \-init [OPTIONS] CIPHERDIR
+.SS Mount
+.PP
+gocryptfs [OPTIONS] CIPHERDIR MOUNTPOINT
+.SS Change password
+.PP
+gocryptfs \-passwd [OPTIONS] CIPHERDIR
+.SH DESCRIPTION
+.PP
+Options:
+.TP
+.B \f[B]\-allow_other\f[]
+By default, the Linux kernel prevents any other user (even root) to
+access a mounted FUSE filesystem.
+Settings this option allows access for other users, subject to file
+permission checking.
+Only works if user_allow_other is set in /etc/fuse.conf.
+This option is equivalent to "allow_other" plus "default_permissions"
+described in fuse(8).
+.RS
+.RE
+.TP
+.B \f[B]\-config string\f[]
+Use specified config file instead of CIPHERDIR/gocryptfs.conf
+.RS
+.RE
+.TP
+.B \f[B]\-cpuprofile string\f[]
+Write cpu profile to specified file
+.RS
+.RE
+.TP
+.B \f[B]\-d, \-debug\f[]
+Enable debug output
+.RS
+.RE
+.TP
+.B \f[B]\-diriv\f[]
+Use per\-directory file name IV (default true) This flag is useful when
+recovering old gocryptfs filesystems using "\-masterkey".
+It is ignored (stays at the default) otherwise.
+.RS
+.RE
+.TP
+.B \f[B]\-emenames\f[]
+Use EME filename encryption (default true), implies diriv.
+This flag is useful when recovering old gocryptfs filesystems using
+"\-masterkey".
+It is ignored (stays at the default) otherwise.
+.RS
+.RE
+.TP
+.B \f[B]\-extpass string\f[]
+Use an external program (like ssh\-askpass) for the password prompt.
+The program should return the password on stdout, a trailing newline is
+stripped by gocryptfs.
+Using something like "cat /mypassword.txt" allows to mount the gocryptfs
+filesytem without user interaction.
+.RS
+.RE
+.TP
+.B \f[B]\-f\f[]
+Stay in the foreground instead of forking away.
+.RS
+.RE
+.TP
+.B \f[B]\-fusedebug\f[]
+Enable fuse library debug output
+.RS
+.RE
+.TP
+.B \f[B]\-gcmiv128\f[]
+Use an 128\-bit IV for GCM encryption instead of Go\[aq]s default of 96
+bits (default true).
+This pushes back the birthday bound for IV collisions far enough to make
+it irrelevant.
+This flag is useful when recovering old gocryptfs filesystems using
+"\-masterkey".
+It is ignored (stays at the default) otherwise.
+.RS
+.RE
+.TP
+.B \f[B]\-init\f[]
+Initialize encrypted directory
+.RS
+.RE
+.TP
+.B \f[B]\-longnames\f[]
+Store names longer than 176 bytes in extra files (default true) This
+flag is useful when recovering old gocryptfs filesystems using
+"\-masterkey".
+It is ignored (stays at the default) otherwise.
+.RS
+.RE
+.TP
+.B \f[B]\-masterkey string\f[]
+Mount with explicit master key specified on the command line.
+This option can be used to mount a gocryptfs filesystem without a config
+file.
+Note that the command line, and with it the master key, is visible to
+anybody on the machine who can execute "ps \-auxwww".
+.RS
+.RE
+.TP
+.B \f[B]\-memprofile string\f[]
+Write memory profile to specified file.
+This is useful when debugging memory usage of gocryptfs.
+.RS
+.RE
+.TP
+.B \f[B]\-nosyslog\f[]
+Diagnostic messages are normally redirected to syslog once gocryptfs
+daemonizes.
+This option disables the redirection and messages will continue be
+printed to stdout and stderr.
+.RS
+.RE
+.TP
+.B \f[B]\-notifypid int\f[]
+Send USR1 to the specified process after successful mount.
+This is used internally for daemonization.
+.RS
+.RE
+.TP
+.B \f[B]\-openssl bool\f[]
+Use OpenSSL instead of built\-in Go crypto (default "auto").
+Using built\-in crypto is 4x slower unless your CPU has AES instructions
+and you are using Go 1.6+.
+In mode "auto", gocrypts chooses the faster option.
+.RS
+.RE
+.TP
+.B \f[B]\-passwd\f[]
+Change password
+.RS
+.RE
+.TP
+.B \f[B]\-plaintextnames\f[]
+Do not encrypt file names
+.RS
+.RE
+.TP
+.B \f[B]\-q, \-quiet\f[]
+Quiet \- silence informational messages
+.RS
+.RE
+.TP
+.B \f[B]\-scryptn int\f[]
+scrypt cost parameter logN.
+Setting this to a lower value speeds up mounting but makes the password
+susceptible to brute\-force attacks (default 16)
+.RS
+.RE
+.TP
+.B \f[B]\-version\f[]
+Print version and exit
+.RS
+.RE
+.TP
+.B \f[B]\-wpanic\f[]
+When encountering a warning, panic and exit immediately.
+This is useful in regression testing.
+.RS
+.RE
+.TP
+.B \f[B]\-zerokey\f[]
+Use all\-zero dummy master key.
+This options is only intended for automated testing as it does not
+provide any security.
+.RS
+.RE
+.SH EXAMPLES
+.PP
+Create and mount an encrypted filesystem:
+.PP
+mkdir /tmp/g1 /tmp/g2
+.PP
+gocryptfs \-init /tmp/g1
+.PD 0
+.P
+.PD
+gocryptfs /tmp/g1 /tmp/g2
+.SH SEE ALSO
+.PP
+fuse(8)
+.SH AUTHORS
+github.com/rfjakob.