summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Feletto2020-11-18 13:48:25 +0100
committerAndrea Feletto2020-11-18 13:48:25 +0100
commit29cc4ee095aa32c27b7a3a9a7dbd9d8de9033028 (patch)
tree78b0139ea86a5ed724fb1d9447a9be4982483788
downloadaur-29cc4ee095aa32c27b7a3a9a7dbd9d8de9033028.tar.gz
version 1.1.2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..049b4a2a34bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = godef
+ pkgdesc = Print where symbols are defined in Go source code.
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = https://github.com/rogpeppe/godef
+ arch = x86_64
+ license = BSD
+ depends = go
+ provides = godef
+ conflicts = godef-git
+ source = godef-1.1.2.tar.gz::https://github.com/rogpeppe/godef/archive/v1.1.2.tar.gz
+ sha256sums = SKIP
+
+pkgname = godef
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc9ddf46b123
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+
+# Maintainer: Andrea Feletto <andrea@andreafeletto.com>
+
+pkgname=godef
+pkgver=1.1.2
+pkgrel=1
+pkgdesc='Print where symbols are defined in Go source code.'
+arch=('x86_64')
+url='https://github.com/rogpeppe/godef'
+license=('BSD')
+depends=('go')
+provides=('godef')
+conflicts=('godef-git')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/rogpeppe/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ export GOPATH="$srcdir"
+ go build -v -o "$pkgname"
+}
+
+package() {
+ licenses="$pkgdir/usr/share/licenses/$pkgname"
+
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$licenses/LICENSE"
+}