summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjonian2015-12-04 00:44:46 +0200
committerjonian2015-12-04 00:44:46 +0200
commit52c2e041dc22f9cc1f80ad8d92ad3db6ddece340 (patch)
tree9a0893616a3205a033070b2c507362361173d793
downloadaur-52c2e041dc22f9cc1f80ad8d92ad3db6ddece340.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
-rw-r--r--godot.desktop9
-rw-r--r--icons.tar.gzbin0 -> 37975 bytes
4 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e30b4299b70f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = godot-bin
+ pkgdesc = Godot is an advanced, feature packed, multi-platform 2D and 3D game engine. It provides a huge set of common tools, so you can just focus on making your game without reinventing the wheel.
+ pkgver = 1.1
+ pkgrel = 1
+ url = http://www.godotengine.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ provides = godot-bin
+ conflicts = godot
+ replaces = godot
+ source = godot.desktop
+ source = icons.tar.gz
+ md5sums = SKIP
+ md5sums = SKIP
+ source_i686 = http://www.godotengine.org:81/godot_x11-1.1stable.32
+ md5sums_i686 = SKIP
+ source_x86_64 = http://www.godotengine.org:81/godot_x11-1.1stable.64
+ md5sums_x86_64 = SKIP
+
+pkgname = godot-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64273fc2433b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Jonian Guveli <https://github.com/jonian/>
+pkgname=godot-bin
+pkgver=1.1
+pkgrel=1
+pkgdesc="Godot is an advanced, feature packed, multi-platform 2D and 3D game engine. It provides a huge set of common tools, so you can just focus on making your game without reinventing the wheel."
+arch=("i686" "x86_64")
+url="http://www.godotengine.org"
+license=('GPL')
+provides=("godot-bin")
+conflicts=("godot")
+replaces=("godot")
+source=("godot.desktop" "icons.tar.gz")
+source_i686+=("http://www.godotengine.org:81/godot_x11-"$pkgver"stable.32")
+source_x86_64+=("http://www.godotengine.org:81/godot_x11-"$pkgver"stable.64")
+md5sums=("SKIP" "SKIP")
+md5sums_i686=("SKIP")
+md5sums_x86_64=("SKIP")
+
+package() {
+ mkdir -p "$pkgdir/opt/$pkgname"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/icons/hicolor"
+ mkdir -p "$pkgdir/usr/share/applications"
+
+ case $CARCH in
+ "i686")
+ cp "$srcdir/godot_x11-"$pkgver"stable.32" "$pkgdir/opt/$pkgname/godot"
+ ;;
+ "x86_64")
+ cp "$srcdir/godot_x11-"$pkgver"stable.64" "$pkgdir/opt/$pkgname/godot"
+ ;;
+ esac
+
+ cp "$srcdir/godot.desktop" "$pkgdir/usr/share/applications/godot.desktop"
+ cp -a "$srcdir/icons/." "$pkgdir/usr/share/icons/hicolor"
+ cp -a "$srcdir/icons/." "$pkgdir/usr/share/icons/gnome"
+
+ chmod +x "$pkgdir/opt/$pkgname/godot"
+
+ ln -s "/opt/$pkgname/godot" "$pkgdir/usr/bin/godot"
+}
+
diff --git a/godot.desktop b/godot.desktop
new file mode 100644
index 000000000000..e63874e9abb9
--- /dev/null
+++ b/godot.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Godot
+Comment=Application for making games
+Exec=/usr/bin/godot %U
+Icon=godot
+Terminal=false
+Type=Application
+Categories=Utility;Game;
+
diff --git a/icons.tar.gz b/icons.tar.gz
new file mode 100644
index 000000000000..8c0d2b9ddaf7
--- /dev/null
+++ b/icons.tar.gz
Binary files differ