summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Rodriguez Reboredo2023-12-02 12:01:28 -0300
committerMartin Rodriguez Reboredo2023-12-02 12:01:28 -0300
commit340612ad3a532345cdd7b0a8ebdd340c5c273fe4 (patch)
tree52d95a108311679b19ba8e950a50271f4cedf6a8
parent480f4218649149d24210b8243d4a08f83e5fb992 (diff)
downloadaur-340612ad3a532345cdd7b0a8ebdd340c5c273fe4.tar.gz
Update to 4.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6cd3b384fe7..179a5d4920e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = godot-cpp
pkgdesc = C++ bindings for the Godot script API
- pkgver = 4.1.2
+ pkgver = 4.2
pkgrel = 1
url = https://godotengine.org
arch = x86_64
license = MIT
makedepends = cmake
- makedepends = godot=4.1.2
- source = https://github.com/godotengine/godot-cpp/archive/refs/tags/godot-4.1.2-stable.tar.gz
+ makedepends = godot=4.2
+ source = https://github.com/godotengine/godot-cpp/archive/refs/tags/godot-4.2-stable.tar.gz
source = godot-cpp.pc.in
- sha256sums = 59333a122f0d05093a344295b284d0fb8689b62138c033b81e8fcbf492743441
+ sha256sums = a11d619cc148318e7500c18f239e5b89de7051b36e23359692f8e0cfe3fc3494
sha256sums = 675cbdf08979edcf5cbd951b88a6b00b5d5a24fd9c68418b8d7b4c77dcf722a3
pkgname = godot-cpp
diff --git a/PKGBUILD b/PKGBUILD
index c919094bbe6d..4e8f0e6c4441 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Martin Reboredo <yakoyoku@gmail.com>
pkgname=godot-cpp
-pkgver=4.1.2
+pkgver=4.2
pkgrel=1
pkgdesc='C++ bindings for the Godot script API'
arch=('x86_64')
@@ -12,7 +12,7 @@ source=(
https://github.com/godotengine/$pkgname/archive/refs/tags/godot-$pkgver-stable.tar.gz
godot-cpp.pc.in
)
-sha256sums=('59333a122f0d05093a344295b284d0fb8689b62138c033b81e8fcbf492743441'
+sha256sums=('a11d619cc148318e7500c18f239e5b89de7051b36e23359692f8e0cfe3fc3494'
'675cbdf08979edcf5cbd951b88a6b00b5d5a24fd9c68418b8d7b4c77dcf722a3')
prepare() {
@@ -30,7 +30,7 @@ build() {
cmake -Bbuild \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_CXX_FLAGS="-DNDEBUG" \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS -Wno-type-limits" \
-DCMAKE_INSTALL_PREFIX=/usr
cmake --build build
}