summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Rodriguez Reboredo2023-09-15 15:20:44 -0300
committerMartin Rodriguez Reboredo2023-09-15 15:20:44 -0300
commitc7bb679c67ebe4f09e11495f1376d08bce6686d7 (patch)
tree90077876e7e50335d3a823b298e9a280749ca2bd
parent30ca8bd33acb37170603ab2d7bb2c715fc9c7201 (diff)
downloadaur-c7bb679c67ebe4f09e11495f1376d08bce6686d7.tar.gz
Update to 4.1.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
-rw-r--r--godot-cpp.pc.in9
3 files changed, 30 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01c4ddc3eae8..f2947af6c665 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = godot-cpp
pkgdesc = C++ bindings for the Godot script API
- pkgver = 3.5.1
+ pkgver = 4.1.1
pkgrel = 1
url = https://godotengine.org
arch = x86_64
license = MIT
- makedepends = scons
- makedepends = clang
- makedepends = llvm
- depends = godot-headers
- source = https://github.com/godotengine/godot-cpp/archive/refs/tags/godot-3.5.1-stable.tar.gz
+ makedepends = cmake
+ makedepends = godot=4.1.1
+ source = https://github.com/godotengine/godot-cpp/archive/refs/tags/godot-4.1.1-stable.tar.gz
source = godot-cpp.pc.in
- sha256sums = a0ab1f117d30ab01837e39e7ff704bbded282db4643343579b2bca11794f99fc
- sha256sums = fc0b47b2b2edbeef088d0c1a124e597df7474d820eba833ce7822ed670f92974
+ sha256sums = ed8d9be78451cd90fe9078d3be1d8826896520f4accd184e1dc9ea6534353655
+ sha256sums = 675cbdf08979edcf5cbd951b88a6b00b5d5a24fd9c68418b8d7b4c77dcf722a3
pkgname = godot-cpp
diff --git a/PKGBUILD b/PKGBUILD
index b06290d3fccd..f0d744f8ea35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,48 @@
# Maintainer: Martin Reboredo <yakoyoku@gmail.com>
pkgname=godot-cpp
-pkgver=3.5.1
+pkgver=4.1.1
pkgrel=1
pkgdesc='C++ bindings for the Godot script API'
arch=('x86_64')
url='https://godotengine.org'
license=('MIT')
-depends=(godot-headers)
-makedepends=(scons clang llvm)
+makedepends=(cmake godot=$pkgver)
source=(
https://github.com/godotengine/$pkgname/archive/refs/tags/godot-$pkgver-stable.tar.gz
godot-cpp.pc.in
)
-sha256sums=('a0ab1f117d30ab01837e39e7ff704bbded282db4643343579b2bca11794f99fc'
- 'fc0b47b2b2edbeef088d0c1a124e597df7474d820eba833ce7822ed670f92974')
+sha256sums=('ed8d9be78451cd90fe9078d3be1d8826896520f4accd184e1dc9ea6534353655'
+ '675cbdf08979edcf5cbd951b88a6b00b5d5a24fd9c68418b8d7b4c77dcf722a3')
prepare() {
cd "$srcdir"/${pkgname}-godot-${pkgver}-stable
sed "s/@VERSION@/$pkgver/" "$srcdir"/godot-cpp.pc.in > godot-cpp.pc
-
- rm -rf godot-headers
- cp -r /usr/include/godot godot-headers
}
build() {
cd "$srcdir"/${pkgname}-godot-${pkgver}-stable
- scons -j16 platform=linux use_llvm=yes generate_bindings=yes target=release
+ cd gdextension
+ godot --display-driver headless --dump-extension-api --dump-gdextension-interface
+ cd ..
+
+ cmake -Bbuild \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_CXX_FLAGS="-DNDEBUG" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
}
package() {
cd "$srcdir"/${pkgname}-godot-${pkgver}-stable
- install -dm00755 "$pkgdir"/usr/{lib,include}
- install -Dm00644 bin/libgodot-cpp.linux.*.a "$pkgdir"/usr/lib/libgodot-cpp.a
- install -Dm00644 godot-cpp.pc "$pkgdir"/usr/lib/pkgconfig/godot-cpp.pc
- cp -rup include "$pkgdir"/usr/include/godot
- install -Dm00644 LICENSE.md "$pkgdir"/usr/share/licenses/godot-cpp/LICENSE.md
+ install -dm755 "$pkgdir"/usr/{lib,include}
+ install -Dm644 build/bin/libgodot-cpp.linux.*.a "$pkgdir"/usr/lib/libgodot-cpp.a
+ install -Dm644 godot-cpp.pc "$pkgdir"/usr/lib/pkgconfig/godot-cpp.pc
+ cp -rup {,build/gen/}include/godot_cpp "$pkgdir"/usr/include
+ install -Dm644 gdextension/gdextension_interface.h "$pkgdir"/usr/include/godot_cpp
+
+ install -Dm644 LICENSE.md "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.md
}
diff --git a/godot-cpp.pc.in b/godot-cpp.pc.in
index b2bf18262244..7a31e343e8c9 100644
--- a/godot-cpp.pc.in
+++ b/godot-cpp.pc.in
@@ -1,11 +1,10 @@
prefix=/usr
-exec_prefix=/usr/bin
-libdir=/usr/lib
-includedir=/usr/include/godot
+exec_prefix=${prefix}/bin
+libdir=${prefix}/lib
+includedir=${prefix}/include
Name: Godot C++ Bindings
Description: C++ bindings for the Godot script API.
Version: @VERSION@
-Requires: godot
Libs: -lgodot-cpp
-Cflags: -I${includedir}/core -I${includedir}/gen
+Cflags: -I${includedir}/godot_cpp