summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Reboredo2022-01-05 16:44:41 -0300
committerMartin Reboredo2022-01-05 16:44:41 -0300
commitcaf07d119c2e9b799ce964e6fb15624fb4da0898 (patch)
treea5773d7dd066cee6b41a2921d3038a79ddec84f9
downloadaur-caf07d119c2e9b799ce964e6fb15624fb4da0898.tar.gz
Initial commit of godot-cpp
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD44
-rw-r--r--godot-cpp.pc.in11
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6d1c10422f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = godot-cpp
+ pkgdesc = C++ bindings for the Godot script API
+ pkgver = 3.4.2
+ pkgrel = 1
+ url = https://godotengine.org
+ arch = x86_64
+ license = MIT
+ makedepends = scons
+ depends = godot-headers
+ source = https://github.com/godotengine/godot-cpp/archive/refs/tags/godot-3.4.2-stable.tar.gz
+ source = godot-cpp.pc.in
+ sha256sums = c62b679cc775bad1dae188839f43801c50d13e7a3dd7589b760d58dff83ac766
+ sha256sums = fc0b47b2b2edbeef088d0c1a124e597df7474d820eba833ce7822ed670f92974
+
+pkgname = godot-cpp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e41886fb2c95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Martin Reboredo <yakoyoku@gmail.com>
+
+pkgname=godot-cpp
+pkgver=3.4.2
+pkgrel=1
+pkgdesc='C++ bindings for the Godot script API'
+arch=('x86_64')
+url='https://godotengine.org'
+license=('MIT')
+depends=(godot-headers)
+makedepends=(scons)
+source=(
+ https://github.com/godotengine/$pkgname/archive/refs/tags/godot-$pkgver-stable.tar.gz
+ godot-cpp.pc.in
+)
+sha256sums=(
+ c62b679cc775bad1dae188839f43801c50d13e7a3dd7589b760d58dff83ac766
+ fc0b47b2b2edbeef088d0c1a124e597df7474d820eba833ce7822ed670f92974
+)
+
+prepare() {
+ cd "$srcdir"/godot-cpp-*
+
+ sed "s/@VERSION@/$pkgver/" "$srcdir"/godot-cpp.pc.in > godot-cpp.pc
+
+ rm -rf godot-headers
+ cp -r /usr/include/godot godot-headers
+}
+
+build() {
+ cd "$srcdir"/godot-cpp-*
+
+ scons -j16 platform=linux use_llvm=yes generate_bindings=yes target=release
+}
+
+package() {
+ cd "$srcdir"/godot-cpp-*
+
+ install -dm00755 "$pkgdir"/usr/{lib,include}
+ install -Dm00644 bin/libgodot-cpp.linux.*.a "$pkgdir"/usr/lib/libgodot-cpp.a
+ install -Dm00644 godot-cpp.pc "$pkgdir"/usr/lib/pkgconfig/godot-cpp.pc
+ cp -rup include "$pkgdir"/usr/include/godot
+ install -Dm00644 LICENSE.md "$pkgdir"/usr/share/licenses/godot-cpp/LICENSE.md
+}
diff --git a/godot-cpp.pc.in b/godot-cpp.pc.in
new file mode 100644
index 000000000000..b2bf18262244
--- /dev/null
+++ b/godot-cpp.pc.in
@@ -0,0 +1,11 @@
+prefix=/usr
+exec_prefix=/usr/bin
+libdir=/usr/lib
+includedir=/usr/include/godot
+
+Name: Godot C++ Bindings
+Description: C++ bindings for the Godot script API.
+Version: @VERSION@
+Requires: godot
+Libs: -lgodot-cpp
+Cflags: -I${includedir}/core -I${includedir}/gen