summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Brill2023-01-16 23:10:53 +0100
committerChristoph Brill2023-01-16 23:10:53 +0100
commite659d8a48e3bcd150fdb7c098069e578829a31c8 (patch)
treead9cfbcfcf5ed815a016349cb681ee93b640caed
downloadaur-e659d8a48e3bcd150fdb7c098069e578829a31c8.tar.gz
Initial commit of 0.13.0-p1
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df24b9bc09ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = godot-fbx2gltf-bin
+ pkgdesc = A command-line tool for the conversion of the FBX file format to the glTF file format
+ pkgver = 0.13.0
+ pkgrel = 1
+ url = https://github.com/godotengine/FBX2glTF/
+ arch = x86_64
+ license = BSD
+ provides = fbx2gltf-bin
+ conflicts = fbx2gltf-bin
+ source = https://github.com/godotengine/FBX2glTF/releases/download/v0.13.0-p1/FBX2glTF-linux-x86_64.zip
+ sha256sums = 68f7f609125e60197faf2edfdeee7bb0f0087f01e2b260e9b6f942377a6c8931
+
+pkgname = godot-fbx2gltf-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6a0d5b90c38a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+/*.zip
+/*.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f906aa7a9c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Christoph Brill <opensource@christophbrill.de>
+# Contributor: Michael Migliore <mcmigliore+aur@gmail.com>
+
+pkgname=godot-fbx2gltf-bin
+pkgver=0.13.0
+pkgrel=1
+pkgdesc='A command-line tool for the conversion of the FBX file format to the glTF file format'
+arch=('x86_64')
+url="https://github.com/godotengine/FBX2glTF/"
+license=('BSD')
+source=("https://github.com/godotengine/FBX2glTF/releases/download/v${pkgver}-p1/FBX2glTF-linux-x86_64.zip")
+sha256sums=('68f7f609125e60197faf2edfdeee7bb0f0087f01e2b260e9b6f942377a6c8931')
+provides=('fbx2gltf-bin')
+conflicts=('fbx2gltf-bin')
+
+package() {
+ install -d ${pkgdir}/usr/bin
+ install -m755 FBX2glTF-linux-x86_64/FBX2glTF-linux-x86_64 ${pkgdir}/usr/bin/fbx2gltf
+}