summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCristian Porras2015-06-19 13:10:01 -0300
committerCristian Porras2015-06-19 13:10:01 -0300
commit03594141bca05a01e461388f7cb2d63a2f773e7b (patch)
treef4765598190c2c2d79700f501fd4f9582dc340a4
downloadaur-03594141bca05a01e461388f7cb2d63a2f773e7b.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD67
-rw-r--r--godot.desktop8
-rw-r--r--icon.pngbin0 -> 3188 bytes
4 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c6166d0465e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = godot-git
+ pkgdesc = Godot Game Engine.
+ pkgver = 1.1._stable_37af8b4
+ pkgrel = 1
+ url = http://www.godotengine.org
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = scons
+ depends = glu
+ depends = libxcursor
+ depends = alsa-lib
+ depends = freetype2
+ depends = mesa
+ provides = godot
+ conflicts = godot
+ source = git://github.com/okamstudio/godot.git#branch=master
+ source = godot.desktop
+ source = icon.png
+ sha256sums = SKIP
+ sha256sums = d2f5ae30b8c0c3fd8a20a451d34e9e9d0ba1b60a39b1f68484a9a74227c83822
+ sha256sums = b6bb8e42625414303cf7608f08fe63bd3267486bf7a96586ebab05ade5189785
+
+pkgname = godot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b687f628ae99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Cristian Porras <porrascristian@gmail.com>
+# Contributor: Matthew Bentley <matthew@mtbentley.us>
+
+_pkgname=godot
+pkgname=${_pkgname}-git
+pkgver=1.1._stable_37af8b4
+pkgrel=1
+pkgdesc="Godot Game Engine."
+url="http://www.godotengine.org"
+license=('MIT')
+arch=('i686' 'x86_64')
+makedepends=('git' 'scons')
+depends=('glu' 'libxcursor' 'alsa-lib' 'freetype2' 'mesa')
+optdepends=()
+conflicts=("godot")
+provides=("godot")
+_arch=''
+if test "$CARCH" == x86_64; then
+ _arch=('64')
+else
+ _arch=('32')
+fi
+
+source=(
+ "git://github.com/okamstudio/${_pkgname}.git#branch=master"
+ godot.desktop
+ icon.png
+)
+sha256sums=(
+ 'SKIP'
+ 'd2f5ae30b8c0c3fd8a20a451d34e9e9d0ba1b60a39b1f68484a9a74227c83822'
+ 'b6bb8e42625414303cf7608f08fe63bd3267486bf7a96586ebab05ade5189785'
+)
+
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+# pkgrel=4
+ _major=$(cat version.py|grep "major" | sed 's/major=//')
+ _minor=$(cat version.py|grep "minor" | sed 's/minor=//')
+ _revision=$(cat version.py|grep revision|sed 's/revision="$Rev: //' | sed 's/ $"//')
+ _status=$(cat version.py|grep "status" | sed 's/status=//' | sed 's/"//g')
+ _git=$(git describe --always)
+ echo "${_major}.${_minor}.${_revision}_${_status}_${_git}"
+}
+
+build() {
+ cd "${srcdir}"/${_pkgname}
+
+ sed -n '/\/* Copyright/,/IN THE SOFTWARE./p' main/main.cpp | sed 's/\/\*//' | sed 's/\*\///' > LICENSE
+
+ scons platform=x11 target=release_debug
+}
+
+package() {
+
+ cd "${srcdir}"
+
+ install -Dm644 godot.desktop "${pkgdir}"/usr/share/applications/godot.desktop
+ install -Dm644 icon.png "${pkgdir}"/usr/share/pixmaps/godot.png
+
+ cd "${srcdir}"/${_pkgname}
+
+ install -D -m755 bin/godot.x11.opt.tools.${_arch} "${pkgdir}"/usr/bin/godot
+ install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/godot-git/LICENSE
+}
+
diff --git a/godot.desktop b/godot.desktop
new file mode 100644
index 000000000000..1e2e1545c597
--- /dev/null
+++ b/godot.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Godot
+Comment=Application for making games
+Exec=/usr/bin/godot %U
+Icon=godot
+Terminal=false
+Type=Application
+Categories=Utility;Game;
diff --git a/icon.png b/icon.png
new file mode 100644
index 000000000000..2a38417ca48c
--- /dev/null
+++ b/icon.png
Binary files differ