summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCristian Porras2016-12-20 10:36:21 -0300
committerCristian Porras2016-12-20 10:36:21 -0300
commit9292ca48a522eb8d02fe4c09f75d61aeae898883 (patch)
tree751c2429cfe122784a1e3f09c02f41dd25e8c70f
parent99f49e7c4ae5e70bf9023cc92d7a1401cdbe4102 (diff)
downloadaur-9292ca48a522eb8d02fe4c09f75d61aeae898883.tar.gz
add -j4 to build()
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d36022280c4e..e4fb9406a1b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = godot-git
pkgdesc = Godot Game Engine: An advanced, feature packed, multi-platform 2D and 3D game engine.
- pkgver = 2.1.r3700.564ba76
+ pkgver = 2.2.r6022.2c8a172
pkgrel = 1
url = http://www.godotengine.org
arch = i686
@@ -9,6 +9,7 @@ pkgbase = godot-git
makedepends = git
makedepends = scons
makedepends = pulseaudio
+ makedepends = clang
depends = glu
depends = libxcursor
depends = libxinerama
diff --git a/PKGBUILD b/PKGBUILD
index 908952eb33e3..5516fd65688c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=godot
pkgname=${_pkgname}-git
-pkgver=2.2.r5989.ab637bc
+pkgver=2.2.r6022.2c8a172
pkgrel=1
pkgdesc="Godot Game Engine: An advanced, feature packed, multi-platform 2D and 3D game engine."
url="http://www.godotengine.org"
@@ -47,7 +47,7 @@ build() {
sed -n '/\/* Copyright/,/IN THE SOFTWARE./p' main/main.cpp | sed 's/\/\*//' | sed 's/\*\///' > LICENSE
- scons platform=x11 target=release_debug CXX=clang++
+ scons platform=x11 target=release_debug CXX=clang++ -j$(nproc)
}
package() {