summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspeak2019-07-28 12:19:14 +0300
committerspeak2019-07-28 12:19:14 +0300
commitefc3ec45d5ae10de090a9d91f6ee5e321e5afdf1 (patch)
tree89af4437482ade42cb1b757b2c5b1906341abed8
downloadaur-efc3ec45d5ae10de090a9d91f6ee5e321e5afdf1.tar.gz
Initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD64
-rw-r--r--godot.desktop8
-rw-r--r--icon.pngbin0 -> 11155 bytes
4 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b42fad1d6416
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = godot-git-alsa
+ pkgdesc = Godot Game Engine: An advanced, feature packed, multi-platform 2D and 3D game engine.
+ pkgver = 3.2.r22290.22c843b0c4
+ pkgrel = 1
+ url = http://www.godotengine.org
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = scons
+ makedepends = clang
+ makedepends = pkgconf
+ depends = glu
+ depends = libxcursor
+ depends = libxinerama
+ depends = alsa-lib
+ depends = freetype2
+ depends = mesa
+ provides = godot
+ conflicts = godot
+ conflicts = godot-git
+ source = git://github.com/godotengine/godot.git#branch=master
+ source = godot.desktop
+ source = icon.png
+ sha256sums = SKIP
+ sha256sums = 2ae039a3879b23e157f2125e0b326fa1ef66d56bfd596c790e8943d27652e93a
+ sha256sums = 99f9d17c4355b274ef0c08069cf6e756a98cd5c9d9d22d1b39f79538134277e1
+
+pkgname = godot-git-alsa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6fe2e783134
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: speak <speakk@gmail.com>
+# Contributor: Matthew Bentley <matthew@mtbentley.us>
+# Contributor: Cristian Porras <porrascristian@gmail.com>
+
+_pkgname=godot
+pkgname=${_pkgname}-git-alsa
+pkgver=3.2.r22290.22c843b0c4
+pkgrel=1
+pkgdesc="Godot Game Engine: An advanced, feature packed, multi-platform 2D and 3D game engine."
+url="http://www.godotengine.org"
+license=('MIT')
+arch=('i686' 'x86_64')
+makedepends=('git' 'scons' 'clang' 'pkgconf')
+depends=('glu' 'libxcursor' 'libxinerama' 'alsa-lib' 'freetype2' 'mesa')
+optdepends=()
+conflicts=("godot" "godot-git")
+provides=("godot")
+_arch=''
+if test "$CARCH" == x86_64; then
+ _arch=('64')
+else
+ _arch=('32')
+fi
+
+source=(
+ "git://github.com/godotengine/${_pkgname}.git#branch=master"
+ godot.desktop
+ icon.png
+)
+sha256sums=(
+ 'SKIP'
+ '2ae039a3879b23e157f2125e0b326fa1ef66d56bfd596c790e8943d27652e93a'
+ '99f9d17c4355b274ef0c08069cf6e756a98cd5c9d9d22d1b39f79538134277e1'
+)
+
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ _major=$(cat version.py|grep "major" | sed 's/major = //')
+ _minor=$(cat version.py|grep "minor" | sed 's/minor = //')
+ _revision=$(printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)")
+ echo "${_major}.${_minor}.${_revision}"
+
+}
+
+build() {
+ cd "${srcdir}"/${_pkgname}
+ sed -n '/\/* Copyright/,/IN THE SOFTWARE./p' main/main.cpp | sed 's/\/\*//' | sed 's/\*\///' > LICENSE
+ scons platform=x11 use_llvm=no pulseaudio=no target=release_debug -j$(nproc)
+}
+
+package() {
+
+ cd "${srcdir}"
+
+ install -Dm644 godot.desktop "${pkgdir}"/usr/share/applications/godot.desktop
+ install -Dm644 icon.png "${pkgdir}"/usr/share/pixmaps/godot.png
+
+ cd "${srcdir}"/${_pkgname}
+
+ install -D -m755 bin/godot.x11.opt.tools.${_arch} "${pkgdir}"/usr/bin/godot
+ install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/godot-git/LICENSE
+}
+
diff --git a/godot.desktop b/godot.desktop
new file mode 100644
index 000000000000..84d7b735d791
--- /dev/null
+++ b/godot.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Godot
+Comment=Application for making games
+Exec=/usr/bin/godot %U
+Icon=godot
+Terminal=false
+Type=Application
+Categories=Development;
diff --git a/icon.png b/icon.png
new file mode 100644
index 000000000000..29c4a7b8fcd2
--- /dev/null
+++ b/icon.png
Binary files differ