summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortas2021-10-26 04:45:27 -0400
committertas2021-10-26 04:45:27 -0400
commit6a4642923e51f6450f70caf791a070413afbf536 (patch)
treefdc3d119b1eac6818e719325388abb04c5fef0a6
parent42b61538a3578f3d24c4ec634be3e1168bc9f341 (diff)
downloadaur-6a4642923e51f6450f70caf791a070413afbf536.tar.gz
first commit; only loosely tested
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
-rw-r--r--godot-mono.desktop (renamed from godot.desktop)6
3 files changed, 38 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8656fc41f1fc..0d01f8ec8407 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
-pkgbase = godot-git
- pkgdesc = Godot Game Engine: An advanced, feature packed, multi-platform 2D and 3D game engine.
- pkgver = 4.0.dev
- pkgrel = 3
+pkgbase = godot-mono-git
+ pkgdesc = Godot Game Engine: An advanced, feature packed, multi-platform 2D and 3D game engine. (C#/Mono integration)
+ pkgver = 4.0.r1.f2cf52e
+ pkgrel = 1
url = http://www.godotengine.org
arch = i686
arch = x86_64
@@ -18,12 +18,12 @@ pkgbase = godot-git
depends = alsa-lib
depends = freetype2
depends = mesa
- provides = godot
- conflicts = godot
- source = godot.desktop
+ depends = mono
+ provides = godot-mono
+ conflicts = godot-mono
+ source = godot-mono.desktop
source = icon.png
- sha256sums = 2ae039a3879b23e157f2125e0b326fa1ef66d56bfd596c790e8943d27652e93a
+ sha256sums = 9e5c418d381aaf954c058701b4b4eadbdd767f318af0898d458a74aae111aed5
sha256sums = 99f9d17c4355b274ef0c08069cf6e756a98cd5c9d9d22d1b39f79538134277e1
-pkgname = godot-git
-
+pkgname = godot-mono-git
diff --git a/PKGBUILD b/PKGBUILD
index fdaa52712bc1..ea5956346ae9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,18 @@
# Contributor: Matthew Bentley <matthew@mtbentley.us>
_pkgname=godot
-pkgname=${_pkgname}-git
-pkgver=4.0.r1.64faa37
+pkgname=${_pkgname}-mono-git
+pkgver=4.0.r1.f2cf52e
pkgrel=1
-pkgdesc="Godot Game Engine: An advanced, feature packed, multi-platform 2D and 3D game engine."
+pkgdesc="Godot Game Engine: An advanced, feature packed, multi-platform 2D and 3D game engine. (C#/Mono integration)"
url="http://www.godotengine.org"
license=('MIT')
arch=('i686' 'x86_64')
-makedepends=('git' 'scons' 'pulseaudio' 'pkgconf' 'xorg-xrandr' 'yasm')
-depends=('glu' 'libxcursor' 'libxinerama' 'alsa-lib' 'freetype2' 'mesa')
+makedepends=('git' 'scons' 'pulseaudio' 'pkgconf' 'xorg-xrandr' 'yasm')
+depends=('glu' 'libxcursor' 'libxinerama' 'alsa-lib' 'freetype2' 'mesa' 'mono')
optdepends=()
-conflicts=("godot")
-provides=("godot")
+conflicts=("godot-mono")
+provides=("godot-mono")
_arch=''
if test "$CARCH" == x86_64; then
_arch=('64')
@@ -24,11 +24,11 @@ else
fi
source=(
- godot.desktop
+ godot-mono.desktop
icon.png
)
sha256sums=(
- '2ae039a3879b23e157f2125e0b326fa1ef66d56bfd596c790e8943d27652e93a'
+ '9e5c418d381aaf954c058701b4b4eadbdd767f318af0898d458a74aae111aed5'
'99f9d17c4355b274ef0c08069cf6e756a98cd5c9d9d22d1b39f79538134277e1'
)
@@ -54,21 +54,30 @@ pkgver() {
}
build() {
- cd "${srcdir}"/${_pkgname}
- sed -n '/\/* Copyright/,/IN THE SOFTWARE./p' main/main.cpp | sed 's/\/\*//' | sed 's/\*\///' > LICENSE
- scons platform=linuxbsd target=release_debug werror=no -j$((`nproc`+1))
+ ls
+ # cd "${srcdir}"/${_pkgname}
+ # sed -n '/\/* Copyright/,/IN THE SOFTWARE./p' main/main.cpp | sed 's/\/\*//' | sed 's/\*\///' > LICENSE
+ # scons platform=linuxbsd werror=no tools=yes module_mono_enabled=yes mono_glue=no -j$((`nproc`+1))
+ # ./bin/godot.linuxbsd.opt.tools.${_arch}.mono --generate-mono-glue modules/mono/glue
+ # scons platform=linuxbsd target=release_debug werror=no tools=yes module_mono_enabled=yes mono_glue=yes -j$((`nproc`+1))
+ # scons platform=linuxbsd target=release_debug werror=no tools=no module_mono_enabled=yes mono_glue=yes -j$((`nproc`+1))
}
package() {
cd "${srcdir}"
- install -Dm644 godot.desktop "${pkgdir}"/usr/share/applications/godot.desktop
- install -Dm644 icon.png "${pkgdir}"/usr/share/pixmaps/godot.png
+ install -Dm644 godot-mono.desktop "${pkgdir}"/usr/share/applications/godot-mono.desktop
+ install -Dm644 icon.png "${pkgdir}"/usr/share/pixmaps/godot-mono.png
cd "${srcdir}"/${_pkgname}
- install -D -m755 bin/godot.linuxbsd.opt.tools.${_arch} "${pkgdir}"/usr/bin/godot
- install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/godot-git/LICENSE
+ # install -D -m755 bin/godot.linuxbsd.opt.tools.${_arch}.mono "${pkgdir}"/usr/bin/godot
+ mkdir "${pkgdir}"/opt
+ mkdir "${pkgdir}"/usr/bin
+ cp -R bin/ "${pkgdir}"/opt/godot-mono
+ chmod -R 755 "${pkgdir}"/opt/godot-mono
+ ln -s "${pkgdir}"/opt/godot-mono/godot.linuxbsd.opt.tools.${_arch}.mono "${pkgdir}"/usr/bin/godot-mono
+ install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/godot-mono-git/LICENSE
}
diff --git a/godot.desktop b/godot-mono.desktop
index 84d7b735d791..459c95876db3 100644
--- a/godot.desktop
+++ b/godot-mono.desktop
@@ -1,8 +1,8 @@
[Desktop Entry]
-Name=Godot
+Name=Godot (Mono)
Comment=Application for making games
-Exec=/usr/bin/godot %U
-Icon=godot
+Exec=/usr/bin/godot-mono %U
+Icon=godot-mono
Terminal=false
Type=Application
Categories=Development;