summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2023-09-16 16:02:41 -0500
committerHurricanePootis2023-09-16 16:02:41 -0500
commitb6baaafe388c79ce1a3aa9524b2883656bcb4dbc (patch)
treec3ecfced41587d330093823e9de094e8b6e02058
parent99424d0ca40acffc311287803f68e6268e56ae59 (diff)
downloadaur-b6baaafe388c79ce1a3aa9524b2883656bcb4dbc.tar.gz
Update godot-mono-git to be based off of godot-mono-enhanced
-rw-r--r--.SRCINFO50
-rw-r--r--PKGBUILD166
-rw-r--r--godot-mono.desktop8
-rw-r--r--icon.pngbin11155 -> 0 bytes
4 files changed, 135 insertions, 89 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a9926b4e842..e5d735d742b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,47 @@
pkgbase = godot-mono-git
- pkgdesc = Godot Game Engine: An advanced, feature packed, multi-platform 2D and 3D game engine. (C#/Mono integration)
- pkgver = 4.0.r1.897afb6
+ pkgdesc = An advanced, feature packed, multi-platform 2D and 3D game engine built properly
+ pkgver = 4.1.r1867.gba54c34
pkgrel = 1
- url = http://www.godotengine.org
+ url = https://godotengine.org/
arch = i686
arch = x86_64
license = MIT
- makedepends = git
- makedepends = scons
+ makedepends = alsa-lib
+ makedepends = gcc
makedepends = pulseaudio
- makedepends = pkgconf
- makedepends = xorg-xrandr
+ makedepends = scons
makedepends = yasm
- depends = glu
+ makedepends = xorg-server-xvfb
+ makedepends = nuget
+ makedepends = python
+ makedepends = git
+ depends = embree3
+ depends = freetype2
+ depends = graphite
+ depends = harfbuzz
+ depends = harfbuzz-icu
+ depends = libglvnd
+ depends = libspeechd
+ depends = libsquish
+ depends = libtheora
+ depends = libvorbis
+ depends = libwebp
+ depends = libwslay
depends = libxcursor
+ depends = libxi
depends = libxinerama
- depends = alsa-lib
- depends = freetype2
- depends = mesa
- depends = mono
+ depends = libxrandr
+ depends = mbedtls2
+ depends = miniupnpc
+ depends = pcre2
+ depends = dotnet-sdk
provides = godot-mono
+ provides = godot
+ provides = godot-mono-bin
conflicts = godot-mono
- source = godot-mono.desktop
- source = icon.png
- sha256sums = 9e5c418d381aaf954c058701b4b4eadbdd767f318af0898d458a74aae111aed5
- sha256sums = 99f9d17c4355b274ef0c08069cf6e756a98cd5c9d9d22d1b39f79538134277e1
+ conflicts = godot-mono-bin
+ options = !lto
+ source = git+https://github.com/godotengine/godot.git
+ md5sums = SKIP
pkgname = godot-mono-git
diff --git a/PKGBUILD b/PKGBUILD
index 6719c3b22e51..2317b515e7a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,82 +1,118 @@
-# Maintainer: tas <tasgon_@out/look.com>
-# Maintainer: QuantMint <qua/ntmint@/protonm/ail.com>
-# Contributor: Cristian Porras <porrascristian@gmail.com>
-# Contributor: Matthew Bentley <matthew@mtbentley.us>
-
-_pkgname=godot
-pkgname=${_pkgname}-mono-git
-pkgver=4.0.r1.897afb6
+# Maintainer: HurricanePootis <hurricanepootis@protonmail.com>
+_pkgname=godot-mono
+pkgname=godot-mono-git
+pkgver=4.1.r1867.gba54c34
pkgrel=1
-pkgdesc="Godot Game Engine: An advanced, feature packed, multi-platform 2D and 3D game engine. (C#/Mono integration)"
-url="http://www.godotengine.org"
-license=('MIT')
+options=("!lto")
+pkgdesc="An advanced, feature packed, multi-platform 2D and 3D game engine built properly"
arch=('i686' 'x86_64')
-makedepends=('git' 'scons' 'pulseaudio' 'pkgconf' 'xorg-xrandr' 'yasm')
-depends=('glu' 'libxcursor' 'libxinerama' 'alsa-lib' 'freetype2' 'mesa' 'mono')
-optdepends=()
-conflicts=("godot-mono")
-provides=("godot-mono")
-_arch=''
-if test "$CARCH" == x86_64; then
- _arch=('64')
-else
- _arch=('32')
-fi
+url="https://godotengine.org/"
+license=('MIT')
+depends=(embree3 freetype2 graphite harfbuzz harfbuzz-icu libglvnd libspeechd libsquish
+ libtheora libvorbis libwebp libwslay libxcursor libxi libxinerama libxrandr
+ mbedtls2 miniupnpc pcre2 dotnet-sdk)
+makedepends=(alsa-lib gcc pulseaudio scons yasm xorg-server-xvfb nuget python git)
+provides=('godot-mono' 'godot' 'godot-mono-bin')
+conflicts=('godot-mono' 'godot-mono-bin')
+source=("git+https://github.com/godotengine/godot.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/godot"
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/.stable//'
+}
-source=(
- godot-mono.desktop
- icon.png
-)
-sha256sums=(
- '9e5c418d381aaf954c058701b4b4eadbdd767f318af0898d458a74aae111aed5'
- '99f9d17c4355b274ef0c08069cf6e756a98cd5c9d9d22d1b39f79538134277e1'
-)
prepare() {
- if [ ! -d "${srcdir}/${_pkgname}" ]
- then
- cd ${srcdir}
- git clone https://github.com/godotengine/godot.git --branch master --single-branch --depth 1
- else
- cd "${srcdir}/${_pkgname}"
- git fetch --depth 1 origin master
- git reset --hard origin/master
- fi
+ # Update the MIME info, ref FS#77810
+ sed -i 's,xmlns="https://specifications.freedesktop.org/shared-mime-info-spec",xmlns="http://www.freedesktop.org/standards/shared-mime-info",g' \
+ "${srcdir}/godot"/misc/dist/linux/org.godotengine.Godot.xml
}
-pkgver() {
- cd "${srcdir}/${_pkgname}"
- _major=$(cat version.py|grep "major" | sed 's/major = //')
- _minor=$(cat version.py|grep "minor" | sed 's/minor = //')
- _revision=$(printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)")
- echo "${_major}.${_minor}.${_revision}"
-
-}
+
build() {
- cd "${srcdir}"/${_pkgname}
- sed -n '/\/* Copyright/,/IN THE SOFTWARE./p' main/main.cpp | sed 's/\/\*//' | sed 's/\*\///' > LICENSE
- scons platform=linuxbsd werror=no tools=yes module_mono_enabled=yes mono_glue=no $MAKEFLAGS
- ./bin/godot.linuxbsd.tools.${_arch}.mono --generate-mono-glue modules/mono/glue
- scons platform=linuxbsd target=release_debug werror=no tools=yes module_mono_enabled=yes mono_glue=yes $MAKEFLAGS
- scons platform=linuxbsd target=release_debug werror=no tools=no module_mono_enabled=yes mono_glue=yes $MAKEFLAGS
+ cd "${srcdir}/godot"
+
+ #Build temporary binaries to generate needed files for mono support
+ export BUILD_NAME=arch_linux
+ scons -j$(nproc) \
+ CFLAGS="$CFLAGS -fPIC -Wl,-z,relro,-z,now -w -I/usr/include/mbedtls2" \
+ CXXFLAGS="$CXXFLAGS -fPIC -Wl,-z,relro,-z,now -w -I/usr/include/mbedtls2" \
+ LINKFLAGS="$LDFLAGS -L/usr/lib/mbedtls2" \
+ lto=none \
+ arch=$CARCH \
+ builtin_embree=no \
+ builtin_enet=yes \
+ builtin_freetype=no \
+ builtin_msdfgen=yes \
+ builtin_glslang=yes \
+ builtin_graphite=no \
+ builtin_harfbuzz=no \
+ builtin_icu4c=yes \
+ builtin_libogg=no \
+ builtin_libpng=no \
+ builtin_libtheora=no \
+ builtin_libvorbis=no \
+ builtin_libwebp=no \
+ builtin_wslay=yes \
+ builtin_mbedtls=no \
+ builtin_miniupnpc=no \
+ builtin_pcre2=no \
+ builtin_pcre2_with_jit=no \
+ builtin_recastnavigation=yes \
+ builtin_rvo2=yes \
+ builtin_squish=no \
+ builtin_xatlas=yes \
+ builtin_zlib=no \
+ builtin_zstd=no \
+ colored=yes \
+ platform=linuxbsd \
+ production=yes \
+ pulseaudio=yes \
+ system_certs_path=/etc/ssl/certs/ca-certificates.crt \
+ target=editor \
+ use_llvm=no \
+ werror=no \
+ module_mono_enabled=yes \
+ mono_glue=no
+
+ xvfb-run -s "-screen 0 1920x1080x24 -nolisten local" bin/godot.linuxbsd.editor.x86_64.mono --generate-mono-glue modules/mono/glue
+
+ # Build normal binaries
+ modules/mono/build_scripts/build_assemblies.py --godot-output-dir=./bin --godot-platform=linuxbsd
}
package() {
+ install -d \
+ "${pkgdir}/opt/${_pkgname}/" \
+ "${pkgdir}/usr/bin/" \
+ "${pkgdir}/usr/share/applications/"
- cd "${srcdir}"
+ rsync -a \
+ "${srcdir}/godot/bin" "${pkgdir}/opt/${_pkgname}"
- install -Dm644 godot-mono.desktop "${pkgdir}"/usr/share/applications/godot-mono.desktop
- install -Dm644 icon.png "${pkgdir}"/usr/share/pixmaps/godot-mono.png
+ # I have to use TERM=xterm because of an bug in mono
+ cat > "${pkgdir}/usr/bin/${_pkgname}" <<-EOF
+ #!/usr/bin/env bash
+ /opt/godot-mono/bin/godot.linuxbsd.editor.x86_64.mono
+ EOF
- cd "${srcdir}"/${_pkgname}
+ chmod a+x ${pkgdir}/usr/bin/${_pkgname}
- # install -D -m755 bin/godot.linuxbsd.opt.tools.${_arch}.mono "${pkgdir}"/usr/bin/godot
- mkdir "${pkgdir}"/opt
- mkdir "${pkgdir}"/usr/bin
- cp -R bin/ "${pkgdir}"/opt/godot-mono
- chmod -R 755 "${pkgdir}"/opt/godot-mono
- ln -s /opt/godot-mono/godot.linuxbsd.opt.tools.${_arch}.mono "${pkgdir}"/usr/bin/godot-mono
- install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/godot-mono-git/LICENSE
-}
+ install -Dm644 \
+ "${srcdir}/godot/icon.svg" \
+ "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${_pkgname}.svg"
+ cat > "${pkgdir}/usr/share/applications/${_pkgname}.desktop" <<-EOF
+ [Desktop Entry]
+ Type=Application
+ Name=Godot Mono
+ GenericName=Godot 2D and 3D game engine
+ Comment=Godot is an Open-Source game engine for 2D and 3D games
+ Keywords=game-dev;development;
+ Categories=Development;
+ Exec=/usr/bin/${_pkgname}
+ Icon=${_pkgname}
+ EOF
+}
diff --git a/godot-mono.desktop b/godot-mono.desktop
deleted file mode 100644
index 459c95876db3..000000000000
--- a/godot-mono.desktop
+++ /dev/null
@@ -1,8 +0,0 @@
-[Desktop Entry]
-Name=Godot (Mono)
-Comment=Application for making games
-Exec=/usr/bin/godot-mono %U
-Icon=godot-mono
-Terminal=false
-Type=Application
-Categories=Development;
diff --git a/icon.png b/icon.png
deleted file mode 100644
index 29c4a7b8fcd2..000000000000
--- a/icon.png
+++ /dev/null
Binary files differ