summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2023-10-12 20:40:36 +0200
committerFabioLolix2023-10-12 20:40:36 +0200
commitdafac41929e928efb69a0e2a47c89a3ff00564a5 (patch)
treed2d119fd6e921f0c93dfc9a6a287ba295a92e6a3
parent3418b2f12f5c6956f344f9e4e79d181bf2b4425b (diff)
downloadaur-dafac41929e928efb69a0e2a47c89a3ff00564a5.tar.gz
revision
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD30
2 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d801633eaa0f..4d147e9a5a01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = godot-mono-git
pkgdesc = An advanced, feature packed, multi-platform 2D and 3D game engine built properly
- pkgver = 4.1.r1867.gba54c34
- pkgrel = 2
+ pkgver = 4.1.r2674.gb137180
+ pkgrel = 1
url = https://godotengine.org/
- arch = i686
arch = x86_64
+ arch = i686
license = MIT
makedepends = alsa-lib
makedepends = gcc
@@ -15,6 +15,7 @@ pkgbase = godot-mono-git
makedepends = nuget
makedepends = python
makedepends = git
+ makedepends = rsync
depends = embree3
depends = freetype2
depends = graphite
@@ -36,11 +37,8 @@ pkgbase = godot-mono-git
depends = pcre2
depends = dotnet-sdk
provides = godot-mono
- provides = godot
- provides = godot-mono-bin
conflicts = godot-mono
- conflicts = godot-mono-bin
source = git+https://github.com/godotengine/godot.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = godot-mono-git
diff --git a/PKGBUILD b/PKGBUILD
index a34d4155edf5..8c6caa9a51b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,37 @@
# Maintainer: HurricanePootis <hurricanepootis@protonmail.com>
+# Contributor: tas <tasgon_@out/look.com>
+# Contributor: QuantMint <qua/ntmint@/protonm/ail.com>
+# Contributor: Cristian Porras <porrascristian@gmail.com>
+# Contributor: Matthew Bentley <matthew@mtbentley.us>
+
_pkgname=godot-mono
pkgname=godot-mono-git
-pkgver=4.1.r1867.gba54c34
-pkgrel=2
+pkgver=4.1.r2674.gb137180
+pkgrel=1
pkgdesc="An advanced, feature packed, multi-platform 2D and 3D game engine built properly"
-arch=('i686' 'x86_64')
+arch=(x86_64 i686)
url="https://godotengine.org/"
-license=('MIT')
+license=(MIT)
depends=(embree3 freetype2 graphite harfbuzz harfbuzz-icu libglvnd libspeechd libsquish
- libtheora libvorbis libwebp libwslay libxcursor libxi libxinerama libxrandr
- mbedtls2 miniupnpc pcre2 dotnet-sdk)
-makedepends=(alsa-lib gcc pulseaudio scons yasm xorg-server-xvfb nuget python git)
-provides=('godot-mono' 'godot' 'godot-mono-bin')
-conflicts=('godot-mono' 'godot-mono-bin')
+ libtheora libvorbis libwebp libwslay libxcursor libxi libxinerama libxrandr
+ mbedtls2 miniupnpc pcre2 dotnet-sdk)
+makedepends=(alsa-lib gcc pulseaudio scons yasm xorg-server-xvfb nuget python git rsync)
+provides=(godot-mono)
+conflicts=(godot-mono)
source=("git+https://github.com/godotengine/godot.git")
-md5sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/godot"
git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/.stable//'
}
-
prepare() {
# Update the MIME info, ref FS#77810
sed -i 's,xmlns="https://specifications.freedesktop.org/shared-mime-info-spec",xmlns="http://www.freedesktop.org/standards/shared-mime-info",g' \
"${srcdir}/godot"/misc/dist/linux/org.godotengine.Godot.xml
}
-
-
build() {
cd "${srcdir}/godot"
@@ -95,7 +97,7 @@ package() {
#!/usr/bin/env bash
/opt/godot-mono/bin/godot.linuxbsd.editor.x86_64.mono
EOF
-
+
chmod a+x ${pkgdir}/usr/bin/${_pkgname}
install -Dm644 \