summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2018-08-14 17:43:13 +0200
committerChristopher Arndt2018-08-14 17:43:13 +0200
commitc13e34fb55120020138443489fa636229d2e78c5 (patch)
tree69190e5c2f9cc5ccfe46dc28825d37f56b2ce93f
parentabe365ad552d3b0a9c1fd1bf108efc70555d3959 (diff)
downloadaur-c13e34fb55120020138443489fa636229d2e78c5.tar.gz
Use gdosc develop branch; make sure ccache is used if enabled
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2857bbab5786..f7914bbfcad3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = godot-osc-git
pkgdesc = An advanced, feature packed, multi-platform 2D and 3D game engine (git version with OSC support)
- pkgver = 3.1.r15659.c4e75aa63
+ pkgver = 3.1.r15719.bbdb6cf16
pkgrel = 1
url = http://www.godotengine.org
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 0c1d08763df8..67174f08b98d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=godot
pkgname=${_pkgname}-osc-git
-pkgver=3.1.r15659.c4e75aa63
+pkgver=3.1.r15719.bbdb6cf16
pkgrel=1
pkgdesc="An advanced, feature packed, multi-platform 2D and 3D game engine (git version with OSC support)"
url="http://www.godotengine.org"
@@ -41,13 +41,22 @@ prepare() {
ln -sf "${srcdir}/gdosc" modules/gdosc
cd modules/gdosc
+ git checkout develop
git submodule update --init
}
build() {
cd "${srcdir}/${_pkgname}"
- scons -j$(nproc) target=release_debug platform=x11 use_llvm=yes bits=${_arch}
+ # SCons apparently uses full path for calling the compiler
+ # so we have to tell it to use ccache explicitly.
+ if echo $PATH | grep -q /usr/lib/ccache && test -x /usr/lib/ccache/bin/clang++ ; then
+ CXX=/usr/lib/ccache/bin/clang++
+ else
+ CXX=/usr/bin/clang++
+ fi
+
+ scons -j$(nproc) target=release_debug platform=x11 use_llvm=yes bits=${_arch} CXX=$CXX
}
package() {