summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortperraut2018-06-11 17:06:08 +0200
committertperraut2018-06-11 17:06:08 +0200
commit009a265d16936eba873c013dd11e97ba6b7ddad8 (patch)
treeebb840f649cc36876c2868ae10c62db8dce90f1b
downloadaur-009a265d16936eba873c013dd11e97ba6b7ddad8.tar.gz
Add file for godot-rc3 build
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD41
-rw-r--r--godot.desktop9
-rw-r--r--icons.tar.gzbin0 -> 37975 bytes
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..688de5659bc2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = godot-rc-bin
+ pkgdesc = Godot is an advanced, feature packed, multi-platform 2D and 3D game engine. It provides a huge set of common tools, so you can just focus on making your game without reinventing the wheel.
+ pkgver = 3.0.3
+ pkgrel = 3
+ url = http://www.godotengine.org
+ arch = i686
+ arch = x86_64
+ license = MIT
+ provides = godot-rc-bin
+ conflicts = godot
+ conflicts = godot-git
+ conflicts = godot-bin
+ replaces = godot
+ replaces = godot-git
+ replaces = godot-bin
+ source = godot.desktop
+ source = icons.tar.gz
+ md5sums = fa7422332b97ab8430ea7628ec8b0880
+ md5sums = 9dbfaa636daf7737899de6a28c33c3be
+ source_i686 = godot-rc-bin-3.0.3::https://downloads.tuxfamily.org/godotengine/3.0.3/rc3/Godot_v3.0.3-rc3_x11.32.zip
+ md5sums_i686 = c421ba8cb37f164ba9608f65c6addaba
+ source_x86_64 = godot-rc-bin-3.0.3::https://downloads.tuxfamily.org/godotengine/3.0.3/rc3/Godot_v3.0.3-rc3_x11.64.zip
+ md5sums_x86_64 = 8128063b3c42c319a60838a81f685ff7
+
+pkgname = godot-rc-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bd707a88419
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Thomas Perraut <https://github.com/tperraut/>
+pkgname=godot-rc-bin
+pkgver=3.0.3
+pkgrel=3
+pkgdesc="Godot is an advanced, feature packed, multi-platform 2D and 3D game engine. It provides a huge set of common tools, so you can just focus on making your game without reinventing the wheel."
+arch=("i686" "x86_64")
+url="http://www.godotengine.org"
+license=("MIT")
+provides=("godot-rc-bin")
+conflicts=("godot" "godot-git" "godot-bin")
+replaces=("godot" "godot-git" "godot-bin")
+source=("godot.desktop" "icons.tar.gz")
+source_i686+=("$pkgname-$pkgver::https://downloads.tuxfamily.org/godotengine/"$pkgver"/rc"$pkgrel"/Godot_v"$pkgver"-rc"$pkgrel"_x11.32.zip")
+source_x86_64+=("$pkgname-$pkgver::https://downloads.tuxfamily.org/godotengine/"$pkgver"/rc"$pkgrel"/Godot_v"$pkgver"-rc"$pkgrel"_x11.64.zip")
+md5sums=("fa7422332b97ab8430ea7628ec8b0880" "9dbfaa636daf7737899de6a28c33c3be")
+md5sums_i686=("c421ba8cb37f164ba9608f65c6addaba")
+md5sums_x86_64=("8128063b3c42c319a60838a81f685ff7")
+
+package() {
+ mkdir -p "$pkgdir/opt/$pkgname"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/icons/hicolor"
+ mkdir -p "$pkgdir/usr/share/applications"
+
+ case $CARCH in
+ "i686")
+ cp "$srcdir/Godot_v"$pkgver"-rc"$pkgrel"_x11.32" "$pkgdir/opt/$pkgname/godot"
+ ;;
+ "x86_64")
+ cp "$srcdir/Godot_v"$pkgver"-rc"$pkgrel"_x11.64" "$pkgdir/opt/$pkgname/godot"
+ ;;
+ esac
+
+ cp "$srcdir/godot.desktop" "$pkgdir/usr/share/applications/godot.desktop"
+ cp -a "$srcdir/icons/." "$pkgdir/usr/share/icons/hicolor"
+ cp -a "$srcdir/icons/." "$pkgdir/usr/share/icons/gnome"
+
+ chmod +x "$pkgdir/opt/$pkgname/godot"
+
+ ln -s "/opt/$pkgname/godot" "$pkgdir/usr/bin/godot"
+} \ No newline at end of file
diff --git a/godot.desktop b/godot.desktop
new file mode 100644
index 000000000000..e63874e9abb9
--- /dev/null
+++ b/godot.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Godot
+Comment=Application for making games
+Exec=/usr/bin/godot %U
+Icon=godot
+Terminal=false
+Type=Application
+Categories=Utility;Game;
+
diff --git a/icons.tar.gz b/icons.tar.gz
new file mode 100644
index 000000000000..8c0d2b9ddaf7
--- /dev/null
+++ b/icons.tar.gz
Binary files differ