summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWard Segers2018-05-01 16:56:42 +0200
committerWard Segers2018-05-01 16:56:42 +0200
commitc1e837ab50eaa9cb9c962d5e1070e418ddfacaf6 (patch)
tree63447462944809a3537732431b86b473142c45ab
parent1e6a9352d6b3e6a30043f49f28cd3533780253ad (diff)
downloadaur-c1e837ab50eaa9cb9c962d5e1070e418ddfacaf6.tar.gz
Release update (compile errors ignored)
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a279d4e83f22..a21c633ae25a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = godot2
pkgdesc = An advanced, feature packed, multi-platform 2D and 3D game engine. Legacy version.
pkgver = 2.1.4
- pkgrel = 1
+ pkgrel = 2
url = http://www.godotengine.org
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 931f92b70c37..6b4d6c42ae03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=godot2
_pkgname=godot
pkgver=2.1.4
-pkgrel=1
+pkgrel=2
pkgdesc="An advanced, feature packed, multi-platform 2D and 3D game engine. Legacy version."
url="http://www.godotengine.org"
license=('MIT')
@@ -38,12 +38,14 @@ build() {
sed -n '/\/* Copyright/,/IN THE SOFTWARE./p' main/main.cpp | sed 's/\/\*//' | sed 's/\*\///' > LICENSE
+ # The c++11-narrowing warnings have been disabled as the code won't compile otherwise.
scons platform=x11 \
tools=yes \
target=release_debug \
use_llvm=yes \
builtin_openssl=yes \
colored=yes \
+ CCFLAGS="-Wno-c++11-narrowing" \
pulseaudio=no bits=${_arch} -j $((`nproc`+1))
}