summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2024-09-06 16:52:01 -0500
committerHurricanePootis2024-09-06 16:52:01 -0500
commit04e9406a1007d5ffff5f8851bb1402e961385a2b (patch)
treeb378906f1eb168598f419d5d0cd40dca656cb822
parent2d4d8bd968141a54a1b62a303136c914b78b653b (diff)
downloadaur-04e9406a1007d5ffff5f8851bb1402e961385a2b.tar.gz
upgpkg: 3.5.3-7: miniupnpc fix and more explicit deps
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD9
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbf44e870506..458e95a6e27e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = godot3
pkgdesc = Advanced cross-platform 2D and 3D game engine (3.x Branch)
pkgver = 3.5.3
- pkgrel = 6
+ pkgrel = 7
url = https://godotengine.org
arch = x86_64
license = MIT
@@ -25,13 +25,20 @@ pkgbase = godot3
depends = libxrandr
depends = opusfile
depends = miniupnpc
+ depends = zstd
+ depends = zlib
+ depends = glibc
+ depends = libxrender
+ depends = pcre2
+ depends = libx11
+ depends = opus
+ depends = libogg
+ depends = libxext
optdepends = pipewire-alsa
optdepends = pipewire-pulse
source = godot-3.5.3.tar.gz::https://github.com/godotengine/godot/archive/3.5.3-stable.tar.gz
- source = https://gitlab.archlinux.org/archlinux/packaging/packages/godot/-/raw/main/miniupnpc-2.2.8.patch
source = godot3.patch
b2sums = 07ee037803e103f863e56a00c6106d00834870881ec75ecc43f947ea3d6e04a560763aa183661fa6437c4c8307f9231b250f2d51462057add1720d71d2ada827
- b2sums = ad308b3ed7fdd0ee305151c584e1a37c753dc5856b0afc631342c03f386a45723d2193d5a6937598a1b883d847dc3ac9c5f7db3d66ec3f9283f636e301235e50
b2sums = 5ed41b79e0121e66614cce997d8c05b3efafefb45d93a426fe4f63bc9917a8dad8519d3f11021a62d6b3a8f7210f2cc86d03361a51dcf79007b0eb71289c1370
pkgname = godot3
diff --git a/PKGBUILD b/PKGBUILD
index 73d3a23abffb..1888e9ea6e81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,20 +9,19 @@
_pkgname=godot
pkgname=godot3
pkgver=3.5.3
-pkgrel=6
+pkgrel=7
pkgdesc='Advanced cross-platform 2D and 3D game engine (3.x Branch)'
url='https://godotengine.org'
license=(MIT)
arch=(x86_64)
makedepends=(gcc scons yasm alsa-lib pulse-native-provider)
depends=(embree3 freetype2 libglvnd libtheora libvorbis libvpx libwebp libwslay
- libsquish libxcursor libxi libxinerama libxrandr opusfile miniupnpc)
+ libsquish libxcursor libxi libxinerama libxrandr opusfile miniupnpc
+ zstd zlib glibc libxrender pcre2 libx11 opus libogg libxext)
optdepends=(pipewire-alsa pipewire-pulse)
source=("$_pkgname-$pkgver.tar.gz::https://github.com/godotengine/godot/archive/$pkgver-stable.tar.gz"
- "https://gitlab.archlinux.org/archlinux/packaging/packages/godot/-/raw/main/miniupnpc-2.2.8.patch"
"godot3.patch")
b2sums=('07ee037803e103f863e56a00c6106d00834870881ec75ecc43f947ea3d6e04a560763aa183661fa6437c4c8307f9231b250f2d51462057add1720d71d2ada827'
- 'ad308b3ed7fdd0ee305151c584e1a37c753dc5856b0afc631342c03f386a45723d2193d5a6937598a1b883d847dc3ac9c5f7db3d66ec3f9283f636e301235e50'
'5ed41b79e0121e66614cce997d8c05b3efafefb45d93a426fe4f63bc9917a8dad8519d3f11021a62d6b3a8f7210f2cc86d03361a51dcf79007b0eb71289c1370')
prepare() {
@@ -32,7 +31,7 @@ prepare() {
# Make godot build a binary compatible with Godot 4
cd "$srcdir/$_pkgname-$pkgver-stable"
patch -p1 < "$srcdir/godot3.patch"
- patch -p1 < "$srcdir/miniupnpc-2.2.8.patch"
+ sed -i 's/addr, 16/addr, 16, nullptr, 0/g' "$srcdir/$_pkgname-$pkgver-stable/modules/upnp/upnp.cpp"
}
build() {