summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2023-08-16 19:38:47 -0500
committerHurricanePootis2023-08-16 19:38:47 -0500
commitcde27a6757ff9a95eaeca207316014ec5afdd4d9 (patch)
tree7ef79e03066c294b75295a9dda817a9b517c24fc
parent41abf2edf85d7c2dd0590d0ed7e0c2df71eaf0ea (diff)
downloadaur-cde27a6757ff9a95eaeca207316014ec5afdd4d9.tar.gz
Update to embree3, remove mbedtls
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 744d8bec130b..0c97babd88e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = godot3-mono-git
pkgdesc = Advanced cross-platform 2D and 3D game engine (3.x Branch Mono)
pkgver = r34303.338114d
- pkgrel = 1
+ pkgrel = 2
url = https://godotengine.org
arch = x86_64
license = MIT
@@ -12,7 +12,7 @@ pkgbase = godot3-mono-git
makedepends = pulseaudio
makedepends = nuget
makedepends = xorg-server-xvfb
- depends = embree
+ depends = embree3
depends = freetype2
depends = libglvnd
depends = libtheora
@@ -25,7 +25,6 @@ pkgbase = godot3-mono-git
depends = libxi
depends = libxinerama
depends = libxrandr
- depends = mbedtls
depends = miniupnpc
depends = opusfile
depends = dotnet-sdk
diff --git a/PKGBUILD b/PKGBUILD
index e10c14b2a951..41f716d467a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,14 +10,14 @@ _pkgname=godot
pkgname=godot3-mono-git
pkgver=r34303.338114d
_pkgverbranch=3.5
-pkgrel=1
+pkgrel=2
pkgdesc='Advanced cross-platform 2D and 3D game engine (3.x Branch Mono)'
url='https://godotengine.org'
license=(MIT)
arch=(x86_64)
makedepends=(gcc scons yasm alsa-lib pulseaudio nuget xorg-server-xvfb)
-depends=(embree freetype2 libglvnd libtheora libvorbis libvpx libwebp libwslay
- libsquish libxcursor libxi libxinerama libxrandr mbedtls miniupnpc opusfile dotnet-sdk)
+depends=(embree3 freetype2 libglvnd libtheora libvorbis libvpx libwebp libwslay
+ libsquish libxcursor libxi libxinerama libxrandr miniupnpc opusfile dotnet-sdk)
optdepends=(pipewire-alsa pipewire-pulse)
source=("git+https://github.com/godotengine/godot.git#branch=$_pkgverbranch"
"godot3-mono"
@@ -49,7 +49,7 @@ build() {
# enet (contains no upstreamed IPv6 support)
# recast, xatlas
# AUR: libwebm
- local to_unbundle="embree freetype libogg libpng libsquish libtheora libvorbis libvpx libwebp mbedtls miniupnpc opus pcre2 wslay zlib zstd"
+ local to_unbundle="embree freetype libogg libpng libsquish libtheora libvorbis libvpx libwebp miniupnpc opus pcre2 wslay zlib zstd"
local system_libs=""
for _lib in $to_unbundle; do
system_libs+="builtin_"$_lib"=no "