summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2017-02-11 17:17:56 +0100
committerMichael Straube2017-02-11 17:17:56 +0100
commit2b45c7b26a6905d290a401d4da324337d46d501f (patch)
tree25827739c5bcf291d08e881840310a66747fa8c2
parent1a9764c964d7c3c0e2338fff90f2ded93835cbe8 (diff)
downloadaur-2b45c7b26a6905d290a401d4da324337d46d501f.tar.gz
Make split pkg with music pack
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD24
2 files changed, 29 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19ccf81f9225..6d72a4cd628a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,13 +7,20 @@ pkgbase = gods
license = custom
makedepends = setconf
depends = java-runtime
- optdepends = gods-extra-music: mp3 music pack
+ noextract = Gods_extra_music.zip
source = https://jotd.pagesperso-orange.fr/gods/GodsDeluxe-0_9.zip
+ source = http://jotd.free.fr/gods/Gods_extra_music.zip
source = gods.png::http://www.androidfreeware.net/software_images/gods.thumb.png
source = gods.desktop
sha256sums = 38fe593a9ed361c65e4a4c36dd4940cde8c847849f1d5e9f15eb940089428a9c
+ sha256sums = 0b92f6e8a056362af481343df2e31eb001b55e43065556e6f4c625b8933c9ca7
sha256sums = d40a00737cfcc82bb4b24110ac5d162da5dddf6041a5d83b94a2c0104ac3a2e3
sha256sums = 176170bb9642eaf3c37d9d393f122334ae5080c9f9a4b69eea27d49855aa41e0
pkgname = gods
+ optdepends = gods-extra-music: mp3 music pack
+
+pkgname = gods-extra-music
+ pkgdesc = Gods Deluxe, mp3 music pack
+ depends = gods
diff --git a/PKGBUILD b/PKGBUILD
index 500bb9204a6a..4b03c54cb5d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Michael Straube <straubem@gmx.de>
# Contributor: Alexander F Rødseth <xyproto@archlinux.org>
-pkgname=gods
+pkgbase=gods
+pkgname=('gods' 'gods-extra-music')
pkgver=0.9
pkgrel=1
pkgdesc='Gods Deluxe, remake of the platform game Gods by Bitmap Brothers'
@@ -10,22 +11,29 @@ url='http://jotd.pagesperso-orange.fr/gods/'
license=('custom')
depends=('java-runtime')
makedepends=('setconf')
-optdepends=('gods-extra-music: mp3 music pack')
source=("https://jotd.pagesperso-orange.fr/gods/GodsDeluxe-${pkgver/./_}.zip"
+ "http://jotd.free.fr/gods/Gods_extra_music.zip"
"gods.png::http://www.androidfreeware.net/software_images/gods.thumb.png"
"gods.desktop")
sha256sums=('38fe593a9ed361c65e4a4c36dd4940cde8c847849f1d5e9f15eb940089428a9c'
+ '0b92f6e8a056362af481343df2e31eb001b55e43065556e6f4c625b8933c9ca7'
'd40a00737cfcc82bb4b24110ac5d162da5dddf6041a5d83b94a2c0104ac3a2e3'
'176170bb9642eaf3c37d9d393f122334ae5080c9f9a4b69eea27d49855aa41e0')
+noextract=('Gods_extra_music.zip')
prepare() {
find Gods -type f -iname "*.bat" -delete
find Gods -type f -iname "*.dll" -delete
setconf Gods/gods.sh GODS_ROOT_DIR "/usr/share/gods"
chmod +x Gods/scripts/gods_loader.sh
+
+ mkdir Music
+ bsdtar -xf Gods_extra_music.zip -C Music
}
-package() {
+package_gods() {
+ optdepends=('gods-extra-music: mp3 music pack')
+
install -d "$pkgdir/usr/share"
cp -r Gods "$pkgdir/usr/share/gods"
install -Dm755 Gods/gods.sh "$pkgdir/usr/bin/gods"
@@ -34,3 +42,13 @@ package() {
install -Dm644 gods.desktop "$pkgdir/usr/share/applications/gods.desktop"
install -Dm644 gods.png "$pkgdir/usr/share/pixmaps/gods.png"
}
+
+package_gods-extra-music() {
+ pkgdesc='Gods Deluxe, mp3 music pack'
+ depends=('gods')
+
+ install -d "$pkgdir"/usr/share/{gods,licenses/$pkgname}
+ cp -r Music/Gods/music "$pkgdir/usr/share/gods"
+ ln -s /usr/share/licenses/gods/readme.txt \
+ "$pkgdir/usr/share/licenses/$pkgname/readme.txt"
+}