summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesse Luehrs2020-07-11 01:14:56 -0400
committerJesse Luehrs2020-07-11 01:20:54 -0400
commit0ce369b61ce02e291ac3218ebb635caa0f9b30f5 (patch)
treed8b09253c0929c8481f18bfda15ca59314d8e783
downloadaur-0ce369b61ce02e291ac3218ebb635caa0f9b30f5.tar.gz
version 0.0.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..323d332864b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = godwrap
+ pkgdesc = a cronwrapper implementation that ties into influxdb
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/antifuchs/godwrap
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ source = https://github.com/antifuchs/godwrap/archive/v0.0.1.tar.gz
+ sha256sums = 8385a969a5a98b50eb1ef967dd75174085b3faa848f436131b81d349b2acf2bb
+
+pkgname = godwrap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2dd664c345c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Jesse Luehrs <archlinux@tozt.net>
+pkgname=godwrap
+pkgver=0.0.1
+pkgrel=1
+makedepends=('go')
+arch=('i686' 'x86_64')
+url="https://github.com/antifuchs/${pkgname}"
+source=(https://github.com/antifuchs/${pkgname}/archive/v${pkgver}.tar.gz)
+sha256sums=('8385a969a5a98b50eb1ef967dd75174085b3faa848f436131b81d349b2acf2bb')
+pkgdesc="a cronwrapper implementation that ties into influxdb"
+license=('MIT')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ go build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm 755 godwrap -t "${pkgdir}/usr/bin"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}