summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPig Monkey2019-05-19 11:55:28 -0700
committerPig Monkey2019-05-19 11:55:28 -0700
commit6bb7e052c212234e2a0d1cfd627358a91076a04f (patch)
tree7a8d037ca07a6d3231b29639806c2e7d472de738
downloadaur-6bb7e052c212234e2a0d1cfd627358a91076a04f.tar.gz
version 0.1.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f8e77801a8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = goesimage
+ pkgdesc = Download the latest image from a NOAA Geostationary Operational Environment Satellite and set it as the desktop background.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/pigmonkey/goesimage
+ arch = any
+ license = custom: Public Domain
+ depends = feh
+ depends = imagemagick
+ depends = curl
+ source = goesimage-0.1.0.tar.gz::https://github.com/pigmonkey/goesimage/archive/0.1.0.tar.gz
+ md5sums = 3e901d20b59351a347f86d8693358a79
+
+pkgname = goesimage
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..437a291fbbbc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Pig Monkey <pm@pig-monkey.com>
+
+pkgname=goesimage
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Download the latest image from a NOAA Geostationary Operational Environment Satellite and set it as the desktop background."
+arch=("any")
+depends=("feh" "imagemagick" "curl")
+license=('custom: Public Domain')
+url="https://github.com/pigmonkey/goesimage"
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/pigmonkey/${pkgname}/archive/${pkgver}.tar.gz)
+md5sums=('3e901d20b59351a347f86d8693358a79')
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 goesimage "${pkgdir}/usr/bin/goesimage"
+}