summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoshless2020-07-27 22:57:56 +0200
committerRoshless2020-07-27 22:57:56 +0200
commit8cd77547774dcd8b9de122dc9b85cd208356be59 (patch)
treef1170c0e573d4cd897f7013030500478eda1845c
downloadaur-8cd77547774dcd8b9de122dc9b85cd208356be59.tar.gz
Initial upload: gofu 1.1.2-2
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD42
-rw-r--r--gofu.install3
-rw-r--r--gofu.service12
-rw-r--r--gofu.sysusers1
-rw-r--r--gofu.tmpfiles3
6 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8ae2a0ff769
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = gofu
+ pkgdesc = Simple file share service in go
+ pkgver = 1.1.2
+ pkgrel = 2
+ url = https://git.roshless.me/~roshless/gofu
+ install = gofu.install
+ arch = x86_64
+ arch = i686
+ license = AGPL
+ makedepends = git
+ makedepends = go
+ provides = gofu
+ conflicts = gofu
+ backup = var/lib/gofu/config.ini
+ source = https://git.roshless.me/~roshless/gofu/archive/1.1.2.tar.gz
+ source = gofu.service
+ source = gofu.sysusers
+ source = gofu.tmpfiles
+ md5sums = 3402cb0ee0eb25900192f6130a6fcc3d
+ md5sums = b85e2bf437eb4528a319f797c18c2fc3
+ md5sums = b7e1a3c7f09bed0d04e918d7a0a87be7
+ md5sums = 279dcf052b7ac8b83a8781b36071c47e
+
+pkgname = gofu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..324d2449216c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Roshless <pkg@roshless.com>
+
+pkgname=gofu
+pkgrel=2
+pkgver=1.1.2
+pkgdesc='Simple file share service in go'
+url='https://git.roshless.me/~roshless/gofu'
+arch=('x86_64' 'i686')
+license=('AGPL')
+provides=("$pkgname")
+conflicts=("$pkgname")
+makedepends=('git' 'go')
+install=gofu.install
+backup=('var/lib/gofu/config.ini')
+source=("https://git.roshless.me/~roshless/$pkgname/archive/$pkgver.tar.gz"
+ "gofu.service"
+ "gofu.sysusers"
+ "gofu.tmpfiles")
+
+build() {
+ cd $pkgname-$pkgver
+ go build \
+ -trimpath \
+ -o $pkgname .
+}
+
+package() {
+ install -Dm644 $pkgname.service -t "$pkgdir/usr/lib/systemd/system/"
+ install -Dm644 $pkgname.sysusers "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
+ install -Dm644 $pkgname.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
+
+
+ cd $pkgname-$pkgver
+ install -Dm755 $pkgname -t "$pkgdir/usr/bin/"
+ install -D "dist/config.ini" "$pkgdir/var/lib/$pkgname/config.ini"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+}
+
+md5sums=('3402cb0ee0eb25900192f6130a6fcc3d'
+ 'b85e2bf437eb4528a319f797c18c2fc3'
+ 'b7e1a3c7f09bed0d04e918d7a0a87be7'
+ '279dcf052b7ac8b83a8781b36071c47e')
diff --git a/gofu.install b/gofu.install
new file mode 100644
index 000000000000..956f6a8107a8
--- /dev/null
+++ b/gofu.install
@@ -0,0 +1,3 @@
+post_remove() {
+ echo 'You may want to remove gofu user and /var/lib/gofu folder.'
+}
diff --git a/gofu.service b/gofu.service
new file mode 100644
index 000000000000..8fffbac3f889
--- /dev/null
+++ b/gofu.service
@@ -0,0 +1,12 @@
+[Unit]
+After=network.target
+
+[Service]
+Type=simple
+User=gofu
+WorkingDirectory=/var/lib/gofu
+Environment=USER=gofu HOME=/var/lib/gofu
+ExecStart=/usr/bin/gofu
+
+[Install]
+WantedBy=multi-user.target
diff --git a/gofu.sysusers b/gofu.sysusers
new file mode 100644
index 000000000000..fd1d158cde94
--- /dev/null
+++ b/gofu.sysusers
@@ -0,0 +1 @@
+u gofu - "gofu daemon user" /var/lib/gofu
diff --git a/gofu.tmpfiles b/gofu.tmpfiles
new file mode 100644
index 000000000000..1848e85e9e7f
--- /dev/null
+++ b/gofu.tmpfiles
@@ -0,0 +1,3 @@
+d /var/lib/gofu 0700 gofu gofu -
+z /var/lib/gofu/config.ini 0700 gofu gofu
+Z /var/lib/gofu - gofu gofu