summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Fettouhi2015-07-17 19:51:43 +0200
committerAndré Fettouhi2015-07-17 19:51:43 +0200
commit861f8390f15e0ccf6c65b2ddee55bed8d7f443b6 (patch)
tree6299a4cb82d4102166126ab14b6853cf89dfbecc
downloadaur-861f8390f15e0ccf6c65b2ddee55bed8d7f443b6.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
-rw-r--r--gog-blackwell-unbound4
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..703db44b0186
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gog-blackwell-unbound
+ pkgdesc = Meet Rosangela Blackwell, an embittered writer who just found out that she is a medium and that it’s her mission.
+ pkgver = 1.0.0.1
+ pkgrel = 1
+ url = http://www.gog.com/game/blackwell_bundle
+ arch = i686
+ arch = x86_64
+ groups = games
+ license = custom
+ depends = freetype2
+ source = local://gog_blackwell_unbound_1.0.0.1.tar.gz
+ source = gog-blackwell-unbound
+ sha256sums = daf65c58c2db0fa0de4ee36b55826a04ad545c8f84fa7e1a41788fee92d465b9
+ sha256sums = 75d0b04dc0ec4aafa98d5a48577f33f1b9a95041137e5bfc23b551bdfefbf7b2
+
+pkgname = gog-blackwell-unbound
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..361791b44999
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer : André Fettouhi <a.fettouhi@gmail.com>
+
+pkgname=gog-blackwell-unbound
+pkgver=1.0.0.1
+pkgrel=1
+pkgdesc="Meet Rosangela Blackwell, an embittered writer who just found out that she is a medium and that it’s her mission."
+arch=("i686" "x86_64")
+url="http://www.gog.com/game/blackwell_bundle"
+license=("custom")
+groups=("games")
+source=("local://gog_blackwell_unbound_${pkgver}.tar.gz" "gog-blackwell-unbound")
+sha256sums=('daf65c58c2db0fa0de4ee36b55826a04ad545c8f84fa7e1a41788fee92d465b9'
+ '75d0b04dc0ec4aafa98d5a48577f33f1b9a95041137e5bfc23b551bdfefbf7b2')
+depends=(freetype2)
+#options=('!strip')
+PKGEXT=.pkg.tar
+
+package() {
+ mkdir -p "${pkgdir}"/opt/gog/blackwell-unbound
+ cp -r "${srcdir}"/Blackwell\ Unbound/* "${pkgdir}"/opt/gog/blackwell-unbound
+ install -Dm644 "${srcdir}"/Blackwell\ Unbound/support/gog-blackwell-unbound-primary.desktop "${pkgdir}"/usr/share/applications/gog-blackwell-unbound.desktop
+ install -Dm644 "${srcdir}"/Blackwell\ Unbound/support/gog-blackwell-unbound.png "${pkgdir}"/usr/share/pixmaps/gog-blackwell-unbound.png
+ install -Dm644 "${srcdir}"/Blackwell\ Unbound/docs/End\ User\ License\ Agreement.txt "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm755 "${srcdir}/gog-blackwell-unbound" "${pkgdir}/usr/bin/gog-blackwell-unbound"
+}
diff --git a/gog-blackwell-unbound b/gog-blackwell-unbound
new file mode 100644
index 000000000000..470cf10d024b
--- /dev/null
+++ b/gog-blackwell-unbound
@@ -0,0 +1,4 @@
+#!/usr/bin/bash
+gogdir="/opt/gog/blackwell-unbound"
+
+"$gogdir"/start.sh