summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuke Chen2015-12-07 17:16:52 +0800
committerLuke Chen2015-12-07 17:16:52 +0800
commit263ac70d7c915692a7140633aa99d2a47e68b5ff (patch)
treecadc2c5cf8a3d49eb42f5801e86ade6b361815a6
downloadaur-263ac70d7c915692a7140633aa99d2a47e68b5ff.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD28
-rw-r--r--gog-crypt-of-the-necrodancer4
-rw-r--r--gog-crypt-of-the-necrodancer.desktop12
-rw-r--r--gog-crypt-of-the-necrodancer.install18
5 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef1823264d9f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gog-crypt-of-the-necrodancer
+ pkgdesc = A roguelike rhythm game! Move on the beat to navigate ever changing dungeons
+ pkgver = 2.1.0.3
+ pkgrel = 1
+ install = gog-crypt-of-the-necrodancer.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ source = local://gog_crypt_of_the_necrodancer_2.1.0.3.sh
+ source = gog-crypt-of-the-necrodancer
+ source = gog-crypt-of-the-necrodancer.desktop
+ sha256sums = SKIP
+ sha256sums = d80562a04ded4b25bca9738267d1d93d2be8fef74570aa7d00d83471c4e71121
+ sha256sums = 9753ea711a428a24333cb37be1f11a3a35860072723e89dd7599d1842f0f4f89
+ depends_i686 = glibc
+ depends_i686 = alsa-lib
+ depends_i686 = libgl
+ depends_x86_64 = lib32-glibc
+ depends_x86_64 = lib32-alsa-lib
+ depends_x86_64 = lib32-libgl
+
+pkgname = gog-crypt-of-the-necrodancer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4cc66cc9d3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Luke Chen <doomer at yahoo dot com>
+pkgname=gog-crypt-of-the-necrodancer
+_pkgname=crypt-of-the-necrodancer
+pkgver=2.1.0.3
+pkgrel=1
+pkgdesc="A roguelike rhythm game! Move on the beat to navigate ever changing dungeons"
+arch=('i686' 'x86_64')
+license=('custom')
+depends_i686=('glibc' 'alsa-lib' 'libgl')
+depends_x86_64=('lib32-glibc' 'lib32-alsa-lib' 'lib32-libgl')
+optdepends_i686=()
+optdepends_x86_64=()
+install=${pkgname}.install
+source=("local://gog_crypt_of_the_necrodancer_${pkgver}.sh"
+ "$pkgname"
+ "$pkgname.desktop")
+sha256sums=(SKIP
+ 'd80562a04ded4b25bca9738267d1d93d2be8fef74570aa7d00d83471c4e71121'
+ '9753ea711a428a24333cb37be1f11a3a35860072723e89dd7599d1842f0f4f89')
+
+package() {
+ mkdir -p "$pkgdir"/opt/gog/$_pkgname
+ cp -r data/noarch/* "$pkgdir"/opt/gog/$_pkgname
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 $pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 data/noarch/support/icon.png "$pkgdir/usr/share/pixmaps/hicolor/256x256/$pkgname.png"
+ install -Dm644 data/noarch/docs/End\ User\ License\ Agreement.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/gog-crypt-of-the-necrodancer b/gog-crypt-of-the-necrodancer
new file mode 100644
index 000000000000..b73e863dbe12
--- /dev/null
+++ b/gog-crypt-of-the-necrodancer
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+gogdir="/opt/gog/crypt-of-the-necrodancer"
+"$gogdir"/start.sh
diff --git a/gog-crypt-of-the-necrodancer.desktop b/gog-crypt-of-the-necrodancer.desktop
new file mode 100644
index 000000000000..f216ff991535
--- /dev/null
+++ b/gog-crypt-of-the-necrodancer.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Value=1.0
+Type=Application
+Name=Crypt of the NecroDancer
+GenericName=Crypt of the NecroDancer
+Comment=Crypt of the NecroDancer
+Icon=/opt/gog/crypt-of-the-necrodancer/support/icon.png
+Exec="/opt/gog/crypt-of-the-necrodancer/start.sh"
+Categories=Game;
+Path=/opt/gog/crypt-of-the-necrodancer
+
diff --git a/gog-crypt-of-the-necrodancer.install b/gog-crypt-of-the-necrodancer.install
new file mode 100644
index 000000000000..7c653e44d3f3
--- /dev/null
+++ b/gog-crypt-of-the-necrodancer.install
@@ -0,0 +1,18 @@
+post_install() {
+ update-desktop-database -q
+ touch /opt/gog/crypt-of-the-necrodancer/game/data/played.dat
+ touch /opt/gog/crypt-of-the-necrodancer/game/data/save_data.xml
+ touch /opt/gog/crypt-of-the-necrodancer/game/data/save_data.xml_TEMP
+ chmod 777 /opt/gog/crypt-of-the-necrodancer/game/data/played.dat
+ chmod 777 /opt/gog/crypt-of-the-necrodancer/game/data/save_data.xml
+ chmod 777 /opt/gog/crypt-of-the-necrodancer/game/data/save_data.xml_TEMP
+ echo "==> The save is located in /opt/gog/crypt-of-the-necrodancer/game/data/"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}